Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I delete totem's history displayed in it's main menu in Natty? For example if I don't want anyone to know I'm watching... ehem Simpsons a lot?

I've tried How can I keep recent files from appearing in Unity? but this doesnt work for Totem.

share|improve this question
    
Have you resolved this issue? –  pl1nk Jun 24 '12 at 23:12
add comment

9 Answers 9

Recent Document history for many Gnome 2 based applications are held in a file in your home folder called .local/share/recently-used.xbel

Either use the Launcher "Home Folder" - select the menu option "View - Show Hidden Files" and navigate to the .local/share folder and delete the file "recently-used.xbel"

Alternatively from the command line

rm ~/.local/share/recently-used.xbel

If you really want to stop recent document history from showing up for your login account then create a file with your favourite Text Editor called .gtkrc-2.0 and save this file in your home folder.

Alternatively from the command line

gedit ~/.gtkrc-2.0

In that file, include on a separate line

gtk-recent-files-max-age = 0 
share|improve this answer
add comment

If you want to permanently remove the recent file list from totem, edit /usr/share/totem/totem.ui as root and change to following line:

<separator name="recent-separator"/>
<placeholder name="recent-placeholder"/>

into

<!--<separator name="recent-separator"/>
<placeholder name="recent-placeholder"/>-->

If you want to reactive history later, all you have to do is remove the part that you added.

share|improve this answer
add comment

Well, that will delete the Zeitgeist history (including Dash) but oddly not the history in Totems main menu. Seems like Totem is saving some kind of own history.

So this is not a duplicate of "How can I keep recent files from appearing in Unity?".

share|improve this answer
add comment

In Unity: go to "Dash Home", search for "System Settings" and then choose "Privacy" -> "Recent Items". Change the time interval and press "Delete history". With the button on the bottom you can turn off recording of your activity at all, however many programs will ignore it.

share|improve this answer
add comment

You can clear the Zeitgeist history (this is the history of recent files that's display in Dash) by using the following commands:

rm ~/.local/share/zeitgeist/activity.sqlite

zeitgeist-daemon --replace

note: it will clear all the other recent files as well.

share|improve this answer
add comment

Heres my workaround: Log off, log in again with "classic ubuntu" (http://www.robotsystematic.com/2011/linux/ubuntu-natty-gnome-2-interface) and clear recent documents as you did in Maverick. When you log in next time to unity-ubuntu, the history of totem is cleared there, too.

share|improve this answer
add comment

If you install Bleachbit from http://bleachbit.sourceforge.net/

Once installed, you select what you want cleaned from the system, this inclused Totem cache & history.

share|improve this answer
add comment

Go to Places -> Recent Documents and clear the list.

share|improve this answer
4  
This only applies if you use the Gnome classic interface. There is no Places -> Recent documents in Unity. –  Scott Severance Dec 21 '11 at 2:34
add comment

Nowadays Totem now uses Gnome Tracker to pick what videos to display in the Recent tab. According to https://wiki.gnome.org/Projects/Tracker/Documentation/First5Minutes, Tracker's db can be cleared by running tracker-control -r

You can also run tracker-preferences, System tab and click the "Yes, remove all of my indexed data" button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.