Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated today (06 Jan 2014), and X11 failed to boot. I tried running startx from a terminal login, and noted that it said that there were no screens found. I trued running nvidia-xconfig, and this failed to resolve the issue. I deleted /etc/X11/xorg.conf, and this got my system up and running on the sucky on-board video, but then trying to re-enable the NVidia card failed. I tried using nvidia-settings, I tried re-installing the driver, I tried rolling it back. None of the above worked.

I am running XUbuntu 13.10-x64 on an Intel Core i7-2600 CPU @ 3.40GHz, 8 GB RAM, most recent updates installed (in fact, that's what broke things).

share|improve this question

2 Answers 2

Working solution:

The recent ubuntu xorg update wiped out the NVidia libglx with a default one that crashes. It's likely only an issue with the NVidia vendor driver. A quick and easy resolution (see assumptions after these commands!) is:

sudo mv /usr/lib/xorg/modules/extensions/libglx.so /usr/lib/xorg/modules/extensions/libglx.so.orig
sudo ln -s /usr/lib/xorg/modules/extensions/libglx.so.331.20 /usr/lib/xorg/modules/extensions/libglx.so

This assumes you were running driver version 331.20. You can go to /usr/lib/xorg/modules/extensions/ and take a look to see what is there. You are basically replacing the default (which should be small) with the one provided by NVidia (which should be substantially larger).

Disclaimer: I handtyped the above commands based upon my setup (Kubuntu Saucy), they may contain typos, enter at your own risk, I am not responsible for puppies spilling out of your CD drive or any other malfeasance wrought upon your system.

Original klunky work-around:

The same thing is occurring to me. I managed to at least be able to log in by disabling all acceleration in KDE. Chrome still kills the desktop (as it uses acceleration as well). Something about this update killed the nvidia acceleration and anything that uses it instantly kills X.

Certainly not a complete answer, but possibly a useful and terrible work-around that may help you find a solution. (I'm using Opera right now, posting this as I seek a resolution myself).

share|improve this answer
    
Do you have an update? Your instructions don't appear to work, but likely cause seems valid. I tried (for second command): sudo ln -s /usr/lib/nvidia-331/libglx.so.331.20 /usr/lib/xorg/modules/extensions/libglx.so –  david6 Jan 10 at 1:36

You can install it manually, using this post: Install Nvidia Drivers in LINUX lightdm xdm gdm 13.10 13.04 Xubuntu Lubuntu Kubuntu. It explains, how to install the driver manually, stop the X service if running, and an alternate solution if that doesn't work. I got sick and tired looking for a solution on this, so I decided to post one myself after it worked for me...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.