Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a nightmare of a time trying to install VMWare Player on my 32-bit 13.10. Apparently my CPU doesn't have 64-bit virtualisation support (I enabled CPU virtualisation in the bios but no joy). Apparently something changed in a certain version of VMWare and in my scenario I'm stuck. I am trying to find out if I can get back to the last version of VMWare that will support my hardware.

All versions of VMWare I've tried give me "One or more of your processors does not have the necessary 64bit extensions to run VMware virtual machines."

Can anyone help? If you're about to ask, it does need to be VMWare and not Virtual Box or other alternatives.

share|improve this question
add comment

2 Answers 2

My understanding is that in version 4 they dropped support for 32bit cpu's. While a 32bit operating system can still be used, it must be running on a 64bit cpu. The following information may not apply to since you said you are running a 32bit OS but didn't state if you had a 32bit cpu.

The links below are for workstation because Vmware posts more information about it, but player is built from workstation so often the same information applies.

VMware Workstation 9 CPU requirements:

http://pubs.vmware.com/workstation-9/index.jsp#com.vmware.ws.get_started.doc/GUID-BBD199AA-C346-4334-9F56-5A42F7328594.html

According to this a 64bit cpu is required.

VMware Workstation 6 (player 2 equivalent):

www.vmware.com/pdf/ws6_manual.pdf

According to the workstation 6 document an x86 or x86-64 cpu can be used. So vmware player 2 should support 32bit cpus.

VMware Workstation 7 (player 3 equivalent?):

www.vmware.com/pdf/ws71_manual.pdf

According to the workstation 7 document some x86 cpus are still supported like the Intel Pentium 4 models that support PAE, however older ones like pentium III are not any longer.

VMware Workstation 8 (player 4 equivalent?):

www.vmware.com/pdf/ws80-getting-started.pdf

According to the workstation 8 document a 64bit cpu is required.

If you have 32bit cpu I would suggest installing VMware Player 3 and if it doesn't work then I guess you will be stuck with version 2. If you have a 64bit cpu but are experiencing issues I would suggest trying version 4 and working your way up.

share|improve this answer
    
many thanks for your input. I am on a 32-bit CPU so it looks like I will try v3 and report back on how it goes. I think I gave up at v4 so this could be what I was looking for. I just hope rolling all the way back to v3 doesn't remove the features I need VMWare for! –  tomfumb Jan 13 at 17:23
add comment

Did you download the 32 bit version from this site :

https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/5_0

share|improve this answer
    
I downloaded the 32-bit v6 from that site but I will give v5 a try tonight –  tomfumb Jan 6 at 17:04
    
Still no progress - v5 produces the same error message as the other versions I tried. I am not looking forward to working through every version –  tomfumb Jan 7 at 4:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.