Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've spent most of today installing Server 11.04. While I can't get network installs to work at all (different issue, I'll post a separate question/bug), when installing from the server CD, all goes well until I reboot. When the computer reboots, I'm presented with a blank screen. I can't switch to other virtual terminals, but the system is running.

By accident I found that if I boot with the monitor unplugged, and plug it in after the computer is booted, the login prompt displays just fine. This is a server, so there is no Xorg involved, but it seems as though it tries to display some unsupported text mode.

I've replicated it on two servers. One is a Dell and one is an HP. They both have onboard video, no secondary video card.

Any idea where to change that?

share|improve this question
    
does your server have an Intel CPU with video capability and another video card? –  hansioux May 4 '11 at 18:57
    
No, I've replicated it on two servers. One is a Dell and one is an HP. They both have onboard video, no secondary video card. (I'll have to look back at work to see if they have identical video chipsets, I'm home now.) –  shawnp0wers May 4 '11 at 19:22
    
@shawn dammit, I have the same problem, though I am installing in VMWare... Did you find any solution? –  Max May 6 '11 at 23:59
    
First of all, log in blindly and check if it works this way. Send pings, for example. If it does - try GRUB - vga= or -nofb -nomodeset kernel option, GFX param in grub, all this stuff. –  Barafu Albino May 12 '11 at 10:42
    
Same problem here... when i disconnect the vga monitor and turn on the server it will stop in the GNU GRUB loader. It will not default to the GRUB_DEFAULT. When i plug it in, there it is stuck on the grub boot loader, i have to plug in a keyboard and press 'enter'... weak sauce. –  capdragon May 16 '11 at 23:33

3 Answers 3

I suggest you turn off he onboard intel graphics and just allow the secondary graphics.You can do this in the BIOS

share|improve this answer

I was having a similar problem, without a monitor, it was not booting.

do a :

sudo nano /etc/default/grub

and take a look at this setting:

GRUB_HIDDEN_TIMEOUT

Is it commented out like so? If so uncomment it (remove the #):

#GRUB_HIDDEN_TIMEOUT=0

According to this post: http://ubuntuforums.org/showthread.php?t=1195275 The GRUB_HIDDEN_TIMEOUT_QUIET is not working right, and i can attest to that. So as a workaround i put the uncommented the GRUB_HIDDEN_TIMEOUT=0 and it now goes boots without a monitor.

GRUB_HIDDEN_TIMEOUT_QUIET=true Used with the GRUB_HIDDEN_TIMEOUT setting. true - No countdown is displayed. The screen will be blank. false - A counter will display on a blank screen for the duration of the GRUB_HIDDEN_TIMEOUT value. This feature currently appears to be broken; the timeout counter isn't appearing when set to 'false' or not set.

share|improve this answer
up vote 0 down vote accepted
+100

A system update fixed this for me. In fact, even a new install (which installs updates) works fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.