Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Gnome desktop environment starts in VT7 by dafault. How do I change it to start in VT12? I have already tried editing /etc/default/console-setup to specify active terminals as 1-11, and then running 'sudo setupcon' from a console terminal. The Gnome desktop environment still starts in VT7 after a restart. I have also added 'setupcon' before the 'exit 0' line in /etc/rc.local, but that had no effect either.

share|improve this question
    
have you tried copying /etc/init/tty6.conf to the locations in between? seems like X11 just takes the next available tty, but i could be wrong. –  hbdgaf May 4 '11 at 17:05
    
I did. In fact, I wanted a log-in prompt in terminals VT7 to VT12, so I could have graphical terminals in VT13 to VT24. I have created tty7.conf to tty12.conf in /etc/init. And I do get log-in prompts in VT8 to VT12. I have also figured out I can start graphical terminals in VT13 to VT24. It is just VT7 that is stubbornly refusing to have anything but the Gnome desktop. –  aphatak May 4 '11 at 20:00
    
This question appears to be abandoned and unanswered. This will be closed. If this question is still valid, please add more detail and flag for it to be reopened. –  fossfreedom Feb 18 '12 at 21:52
add comment

closed as too localized by fossfreedom Feb 18 '12 at 21:53

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.