Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to install Medieval II : Total War under wine. Everything goes well until I am prompted to install the second dvd-rom to finish the install.

No matter what path I supply to the installer it says setup can't find a file on the specified path or disk. I've tried the options shown for D and Z drives, /dev/sr0, /media/myname etc.

I've also had similar problems with Medal of Honour.

Can anyone help?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

With Wine, you must enter BOTH discs before launching the installation, because Wine only reads what was already mounted when it started. It's the same reasoning when you change a program's configuration file (like .js, .ini, or whatever that's is not in the GUI options), it has to be restarted to apply the changes.

Solution 1) Insert both discs then launch the installation.

Solution 2) If you have only one disc-tray (or cd-drive), or if you don't want to restart the installation :

  • Create a new directory somewhere (I'll name it DISC2 but you do what you want):

    mkdir ~/DISC2

  • Copy the CD's content into the new directory with drag-and-drop or commandline (replace /path/to/cd by the path to your mounted CD):

    cp -r /path/to/cd ~/DISC2

  • Under Wine, point the DISC-2 path to ~/DISC2

share|improve this answer
    
I've tried that but get errors copying because it is a 'read only file' system and permission is denied. I suppose that is another question entirely. –  comrademike Jan 5 at 15:30
    
Uh, read-only or not, you should be able to copy the files into your hard-drive. Open Nautilus as root ( gksu nautilus )and retry the copy. –  MrVaykadji Jan 5 at 15:32
    
No, it won't work. I obviously have some other problem beside what I originally thought. –  comrademike Jan 5 at 15:37
    
you can try rm -r ~/DISC2, then sudo mkdir ~/DISC2, then sudo cp -rf /path/to/cd ~/DISC2. –  MrVaykadji Jan 5 at 15:40
    
It's ok now. For some reason the fact that a different dvd was in the drive had not been registered - even after logout! After a fresh start, I did as you suggested and it worked fine, so thanks for the help. –  comrademike Jan 5 at 16:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.