Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.04 64 bit and recently installed qemu-kvm. Now I want to start a 64bit live CD using qemu -m 512 -boot d -cdrom archlinux-2010.05-netinstall-x86_64.iso This loads the image and I can select to boot ArchLinux the normal way, but it will give me an error that I have to use 64bit machine to run this live CD. Now, I tried to get a list of cpu qemu can emulate for me, and ended up with this output:

axle@z370l:~/Downloads$ qemu -cpu ?
x86           [n270]
x86         [athlon]
x86       [pentium3]
x86       [pentium2]
x86        [pentium]
x86            [486]
x86        [coreduo]
x86          [kvm32]
x86         [qemu32]
x86          [kvm64]
x86       [core2duo]
x86         [phenom]
x86         [qemu64]
x86           [host]

So, how do I make qemu emulate a 64bit cpu?

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

I asked myself the same question a few days ago and couldn't figure it out. Now I see your list (perhaps I couldn't find how to get this list?) and the obvious choices seem to be kvm64, qemu64 and host. I also tried core2duo and phenom, they also work.

share|improve this answer
    
Oh... dang it, I got confused by the x86 in front of all these entries... But now it get's a little clearer, since 64bit still is x86_64 ;). This solved the problem. –  axle May 4 '11 at 19:16
add comment

I asked myself the same question a few days ago and couldn't figure it out. Now I see your >list (perhaps I couldn't find how to get this list?) and the obvious choices seem to be >kvm64, qemu64 and host. I also tried core2duo and phenom, they also work.

Running "qemu -cpu qemu64 ..." (or other architectures) did not work for me (on Debian Sid/unstable). I did get my 64bit ISO image to run with "qemu-system-x86_64 ..."

share|improve this answer
    
Thank you. I can confirm that -cpu qemu64 (or the other) did not work for me on Debian Wheezy but qemu-system-x86_64 works. –  Maxime Jul 2 '13 at 14:35
add comment

This command worked well for me, maybe it can help someone else:

qemu /path/to/hdfile -m 900 -vga std -enable-kvm -cdrom ~/file.iso -boot d -net user -usb -cpu kvm64
share|improve this answer
    
Thank you! (ou Obrigado :-) ) –  M. Du Clavier Feb 13 at 16:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.