Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo T520, which is annoyingly loud all the time. My CPU however doesn't do anything and the BIOS is set to "balanced mode".

I tried to check, and the fan control is set to automatic, and even correctly tells the fan to run at low speeds or turn off:

root@xubuntu:~# cat /proc/acpi/ibm/fan 
status:     enabled
speed:      1974
level:      auto

root@xubuntu:~# cat /proc/acpi/ibm/fan 
status:     enabled
speed:      0
level:      auto

However, my fan is ignoring that completely, running happily all the time on full speed despite having the ondemand governor set:

tux@xubuntu:~$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
ondemand
share|improve this question
    
Why do you have different contents of the same file? Is the second what you get when the fan is idle? Does that mean the fan does stop sometimes? Please post the output of cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor. –  terdon Jan 5 at 9:36
    
The fan should be idle, but is still running. even if i get 0 rpm, i can hear it running... cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor ondemand –  kkn Jan 5 at 11:47

1 Answer 1

A few things you can try:

  1. (source) Edit /etc/default/grub and add acpi_osi='Linux' to the GRUB_CMDLINE_LINUX_DEFAULT variable:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='Linux'"
    

    Then run sudo update-grub and reboot.

  2. For tips on controlling a Lenovo's fan, have a look at this page. The thinkwiki webpage in general is always a great source of info for Linux on Lenovo machines.

  3. There is a very nice utility called "Simple ThinkPad Fan Control" which allows you to fine tune the trigger temperatures that change the fan's speed.

  4. If you are on a Dell machine (I know you are not, but someone else may read this), use the i8k module:

    sudo apt-get install i8kutils 
    sudo modprobe i8k
    sudo i8kfan 0 1 
    
  5. If you are dual booting with windows, check the fan settings there. I had a similar problem and the power settings in windows were making changes in the BIOS which then would affect my linux system as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.