Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in my network environment I have two access points with the same ESSID; one of them is near my desktop and another is in another building.

I get signal from both of them, and the connection often switches from the near one to the far one, leading to a connection drop.

How can I force network manager to use only a given AP, ignoring the other?

share|improve this question
add comment

1 Answer

First, find the BSSID (MAC address) of the AP that's further away. See this answer on how to get it.

Then click on the NM indicator → choose Edit Connections... → then click on the Wireless tab. Find the SSID in the list and click on Edit.

Now rename the connection to make it easier tell them apart and untick the Connect automatically checkbox. Also enter the address of the AP in the BSSID field.

That's it. You'll still see both APs in the NM indicator with the same name (don't know if you can change that), but your computer will only automatically connect to the closer one.

share|improve this answer
    
Hi, in my case I try to avoid a 00:00:00:00:00:00 bssid AP, but the editing window you talk about doesn't let me enter that value. Can I do it some other way? Thanks. –  tomyo Feb 18 at 19:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.