Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update-manager brought up an update today, but refused to install it.

"This action would require the installation of packages from not authenticated package sources." (transliterated error message, couldn't locate English original)

That's because of a package from a custom old/flat Debian-style repository, which no gpg keys are available for (and I won't bug the maintainer about it). Also it was working perfectly fine with update-manager before. So I assume there was a recent change.

Is there are an apt.conf setting or an update-manager configuration ability to disable that check? Since it's probably not possible for a single repository, I'd rather disable all checks now. (Typical security outcome for nonsensical restrictions.)

I've worked around the issue now with a manual apt-get upgrade - where the signature-less repository is still a normal warning, not a fatal error. But I would prefer to have a user-friendly solution to this, and again use the update-manager update button when it pops up next time.


Still unresolved. I've found out about the apt-get --allow-unauthenticated option meanwhile. But that doesn't help me for update-manager.

 APT::Get::AllowUnauthenticated "true";

Adding this apt.conf setting also didn't alter the behaviour.

share|improve this question
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 15:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.