Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Xubuntu 13.10 on a 64bit Machine, with kernel 3.11.0-15-generic.

In the Settings panel > Software and updates, tab Additional drivers, I switched the default driver to a proprietary driver. After a reboot, huge problem. I type my password and the X server seems to crash. I can't do anything. I'm only able to switch to another TTY. How can I fix this? I should maybe switch back to the former driver, but how?

My /etc/var/Xorg.0.log is here link

Thanks

UPDATE:

Solved. From tty0, I did sudo aptitude purge fglrx ; sudo dpkg-reconfigure xserver-xorg And everything now works

share|improve this question
1  
Have you tried this from the tty: 'sudo apt-get purge fglrx' and reboot? –  comrademike Jan 5 at 12:06
    
Yes thanks, I tried this, plus dpkg-reconfigure xserver-xorg and everything now works. Thanks. –  Romain Pellerin Jan 5 at 14:47
    
Glad to have been of help! –  comrademike Jan 5 at 15:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.