Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Ok, I've noticed alot of people asking this question. But none of the solutions works for me. Keep in mind I have NEVER touched Ubuntu before. I want to try out Ubuntu and get to know it.

Here is my problem.

When I boot up Ubuntu from my USB device the option to install alongside windows 7 is gone.

I have 2 drives in my computer. One 120GB SSD and one 1TB HDD. I want to install Ubuntu on my SSD where Windows 7 already is installed.

I've read about Ubuntus limitations to 4 partitions, I only got 3 (my 1TB included) So it's only 2 partitions on my SSD. I've reduced my Primary partition on the SSD so Ubuntu can have 10GB. And I've kept those 10GB as "unlocated space". But still it won't detect the partition.

I tried some guys step by step guide, where he used a program named Gdisk. But the terminal in Ubuntu won't recognize the command.

So what should I do now? Any advice?

Please remember that I have no experience with Linux at all, so giving me a lot of advance steps might not help. Just think of me as stupid if that helps :)

Thanks!

share|improve this question

marked as duplicate by NikTh, Radu Rădeanu, Alvar, guntbert, BuZZ-dEE Jan 7 at 20:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
choose something else option to install ubuntu on a seperate ext4 partition. –  Avinash Raj Jan 5 at 3:47
1  
The 4 partitions limitation is not Ubuntu's limitation, but MBR's. Read this answer and as I think you face the same problem, I will vote your question as duplicate. In otherwise edit your question appropriately and I can retract my vote. –  NikTh Jan 5 at 4:23
    
Is Windows hibernated or need chkdsk after resize? Was SSD originally gpt? Or was SSD ever in a RAID configuration. All those in addition to the other issues posted can cause issues. post sudo parted -l and if MBR post sudo fdisk -lu –  oldfred Jan 5 at 19:03

1 Answer 1

I recently had a problem just like yours (I had Windows 8.1). Not showing the "Install alongside Windows" is probably because either you have too many partitions (4) or the disk you're trying to install on is a Dynamic disk (Not MBR), and my case was the latter. Since you say you haven't got all 4 partitions then I'm assuming (although I can't really tell, it would have been much better if you had put some screenshots) that your disk is a dynamic one. To check if that is true:

1) Go into Windows 7

2) Search for "Create and format hard disk partitions" in the start menu and open it

3) After some waiting, the window will open and display all your disks and drives. At the bottom of the window you will see like "Disk 0" (see which one is the SSD drive) and under that it has either written "Dynamic" or "Basic"

4) If the SSD you want to install Ubuntu was Dynamic, proceed:

5) Using a software like AOMEI Partition Manager (Home edition) you can select that disk and convert it to a Basic one without loss of data. (I did that and my Windows still worked. However I had to delete one of my volumes which had normal files in it; I copied them elsewhere).

6) After that, you can now run Ubuntu and you will probably see that option

I hope this helps!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.