Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The other day, I made an ad-hoc wifi network for some LAN gaming. After I disconnected, I tried to reconnect to the wifi network, but it kept saying it couldn't connect. I disabled and re-enabled my wifi to no avail. Thinking that I might get an error message, I restarted nm-applet in a terminal, but no error message came through when I tried to connect. I fiddled with a few of the network settings; nothing helped. I restarted the system, but it still wouldn't connect. Then I had the computer forget the network and reconnected, thinking maybe a fresh start would do the trick. Still no connection.

Finally, fed up, I sent the computer to sleep. Next day I woke up the computer and tried to connect, and it worked.

Now, I'm pretty sure the problem didn't arise from bandwidth issues, because I can usually still connect to the network in those conditions. I don't think it was a router problem, because I could access the network before setting up the WLAN, and anyhow the WLAN wouldn't change any of the existing network's settings. This leaves me with two options:

  1. There was some sort of internal setting (IP address, etc.) which needed to expire to allow the old connection. If so, is there a way to manually reset this in Linux?
  2. There was a router problem. In this case, there's nothing to do but restart the router.

Is there a third option I'm missing? Also, how would I go about troubleshooting something like this?

(As a side note, the other computer which had been connected to my network was running Windows 7, and it also couldn't connect after disconnecting from my ad-hoc network.)

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.