Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why I have no Firefox icon in Dash (like in clean install of Natty)? My system was updated from 10.10 (and from 10.04 in turn). Preferred app for internet is set to Firefox. It's my most often used application, how to fix this?

Dash

Preferred apps

Sorry my Russian locale.

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Since another users dont have that issue, problem was in home dir. I think it was caused by upgrades from 3.0 -> 3.5 -> 4.0 firefox from PPA in the past.

Solved by deletion of some duplicated firefox,*firefox.desktop* files from home dir.

share|improve this answer
add comment

The dash should keep track of your frequently used applications. Firefox should place itself in there if you use it a few times.

share|improve this answer
1  
Think he means the quick choices that come up when you just press super. Mine is for some reason set to Chrome, although Firefox is my preferred browser (and has been set that way for a long time). –  Erik Kronberg May 4 '11 at 13:45
1  
Yes, that's the problem! I want Firefox here –  Extender May 4 '11 at 14:10
add comment

If you right mouse click on an icon in the Unity dock (I'm confused is this the dash?), you can make it's placement there fixed (see image below). So the next time you want to run the application, all you do is click on the associated icon. The reverse can be done for applications you do not want to show up all of the time.

http://i67.photobucket.com/albums/h298/LA_Phantom_photos/Screenshots/dock.jpg

share|improve this answer
1  
this is not the dash :) –  RolandiXor May 27 '11 at 21:53
    
Ahhh...I think I have got it. I reviewed the original pic and I believe that I now understand the dash. Thanks. –  Kory Wnuk May 27 '11 at 22:02
    
Thanks guys, problem is solved already :) –  Extender May 28 '11 at 4:49
add comment

I think that this question covers yours.

So, press Super, type preferred applications, and change the settings there. Do a restart and it should be fixed, I think.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.