Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm not able to build gtkparasite

when i run:

./autogen.sh

i'm get this error

checking for GTK... no
configure: error: Package requirements (gtk+-3.0 >= 3.10.0 gtksourceview-3.0) were not met:

Requested 'gtk+-3.0 >= 3.10.0' but version of GTK+ is 3.6.1
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

So, when i do:

echo $PKG_CONFIG_PATH

it show me a blank, line so i adjust it with:

$ locate pkg-config
/etc/bash_completion.d/pkg-config
/usr/bin/pkg-config
/usr/lib/python2.7/dist-packages/numpy/core/lib/npy-pkg-config
...........
$ export PKG_CONFIG_PATH=/usr/bin/pkgconfig

but the error persist.

How I can do to build this sources?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Requested 'gtk+-3.0 >= 3.10.0' but version of GTK+ is 3.6.1

The program needs at least GTK+ v3.10 but you only have GTK+ v3.6.1

Ubuntu 14.04 will have GTK+ v.3.10. For other version of Ubuntu you need to either find a PPA or other unofficial packages for GTK+ v3.10 or compile it yourself, too (which includes compiling some more libs needed by GTK+).

share|improve this answer
    
Thanks for your answer. But if I install a different versione of Gtk manually, i can break my system? My current Gtk remain the same? –  koMah Jan 4 at 18:09
1  
Overwriting Ubuntu's version of GTK+ may cause trouble. Install your version into /usr/local/ and set $PKG_CONFIG_PATH to /usr/local/lib/pkgconfig/ (or wherever the gtk+*.pc file for your GTK+ is) –  Florian Diesch Jan 4 at 18:19

If you are going to compile manually, you have to install all the depenencies and -dev packages manually.

For gtk+ the command is

sudo apt-get install libgtk-3-dev gtksourceview-dev

You also need who knows what else. Check the README for dependencies and search for them and the -dev packages in the ubuntu database.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.