Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know many people have reported similar problems before, and the solutions seem to work for them but not for me. I'm hoping if I give a description of my exact problem it might help:

I recently got an ASUS 1015E laptop and for about the first week of using it the wireless connection worked perfectly fine. Eventually one day, I suddenly lost the wireless connection. I assumed it was a router problem or something like that, but the internet was still fine on other devices in my house using a wireless connection. After a reboot I regained the connection, but the same thing happened after about 10 minutes. When I lose the signal it keeps showing that it's trying to connect on the icon but it never does. Every 2 minutes or so it will ask for my wifi password again and it will already be entered in, so I just click Connect and it still can't seem to connect. If I click cancel to ignore the password prompt then it stops trying to connect and if I click on the network manager icon it says "Wireless is disabled by hardware switch". I have no hardware switch that disables wifi, but Fn + F2 will disable it. The thing is that I never did do Fn + F2, and when I do "rfkill list all" it shows:

0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

I've tried so many different solutions I can't even count them, and none of them work.

Some of the solutions I've tried, based off of my terminal history:
1. sudo rfkill unblock all
2. Simply editing the connection info and re-entering the wifi password
3. sudo modprobe iwlwifi 11n_disable=1
4. Creating a file in /etc/modprobe.d/ called 'iwlwifi.conf' with one line of code:

options iwlwifi 11n_disable=1

5. Uninstalling recently installed applications
6. sudo modprobe -r iwlwifi
7. sudo modprobe ath5k nohwcrypt
8. Restarting network-manager and networking
9. Running this code and rebooting:

sudo -i
echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf
exit

I was also told to try changing wapf=0 to wapf=1 or 4. None of the three worked.
10. sudo pppoeconf
11. sudo lshw -C network
12. lsmod | grep asus
13. sudo iwlist wlan0 scanning
14. sudo apt-get purge bcmwl-kernel-source
15. sudo modprobe -rv wl
16. sudo modprobe -rv brcmsmac
17. Setting ifupdown managed to false (already was set to false) in /etc/NetworkManager/NetworkManager.conf
18. Editing the /etc/network/interfaces to have only this in it:

auto lo
iface lo inet loopback

Hopefully someone can help here me. It's annoying to need to reboot every 5-10 minutes! Thanks in advance.

share|improve this question
    
Welcome to Ask Ubuntu! Well written question w. plenty of details and proof that you have tried to solve it! Please always ask like this! +1 –  RPi Awesomeness Jan 4 at 21:33
add comment

1 Answer 1

did you try this :

Press Alt+F2, in the box that pops up type: killall nm-applet and press Run. This will shutdown any existing network manager icons that aren't showing up. Then

Press Alt+F2 again and this time type: nm-applet This will launch a fresh network manager applet

this always work for me better than reboot

share|improve this answer
    
Thanks, but this didn't work. I did find a forum thread though that provided a solution specifically for Asus laptops/netbooks. So far it seems to have worked, but it's a bit too early to tell (have to wait for the wireless to cut out again before I can know for sure whether it works or not). Here's the post for anyone else who has the same problem with an Asus laptop: ubuntuforums.org/showthread.php?t=2181558 –  user231751 Jan 4 at 20:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.