Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a secondary 1TB disk. On that disk I have 3 partitions with the ext4 filesystem (600gb, 300gb and 100gb).

I wanted to mount the partitions into some folders inside the home directory. So I added this to /etc/fstab

UUID=bc7599e9-8823-4daf-b0e5-d2ba7dab033d /home/alsar/Pictures ext4 defaults 0 2
UUID=45c34cc6-77ec-44c2-aaa9-514aff27d374 /home/alsar/Other ext4 defaults 0 2
UUID=3753f8be-83b1-42de-824d-b80b58f22945 /home/alsar/Videos ext4 defaults 0 2

When I start the system it says that the partitions are mounted at the specified mount points. But they are not, because the folders are empty.

When I run df -h it says that all three partitions have the size 69GB which actually is the size of the /dev/sda4 partition that is mounted into the home folder.

/dev/sda4             69G   42G   24G  65% /home
/dev/sdb1             69G   42G   24G  65% /home/alsar/Videos
/dev/sdb2             69G   42G   24G  65% /home/alsar/Pictures
/dev/sdb3             69G   42G   24G  65% /home/alsar/Other

If I for instance run sudo umount /dev/sdb3 it says umount: /home/ales/Other: not mounted. If I run mount -a after that the /dev/sdb3 partition gets actually mounted.

I tried another disk, but the problem is the same.

I run Ubuntu 13.10. Any help would be appreciated.

EDIT: It seams to be the problem only when the mount points are inside the home folder (which is the mount point of /dev/sda4. Any other location works fine.

share|improve this question
    
reboot your pc,after that sdb1,sdb2,sdb3 automatically mounted at their mount points. –  Avinash Raj Jan 4 at 15:55
    
I did that in the first place, when I modified the fstab file. –  alsar Jan 4 at 16:01
    
are sure with all of the partition UUID,maybe you're just wrong put it try to cross-check it from Disk and blkid. –  Tommy Aria Pradana Jan 4 at 16:25
    
Checked the UUID multiple times. If the UUID would be wrong I would not be able to mount the partitions at all. But I can mount them to any other location except to a subfolder of home. –  alsar Jan 4 at 18:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.