Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I got stuck with Unity since it does not work at all - I see no system bar nor Unity launcher (3D/2D). Possible causes are: system update/upgrade or playing with drivers (additional fglrx or downloaded from AMD website). I would point on recent system update since I saw there OpenGL-something.

EDIT

How have I reanimated Unity:

FIRST reading askubuntu and Google answers
- reinstalled Unity,
- changed drivers,
THEN reading unity --reset
- fixed broken links to libGL.so and added few more,
THEN reading answers
- enabled Unity in ccsm
THEN reading unity --reset
- added libatiuki.so links to /lib32 and /lib (was only in /lib64).

Now it kind of works, but unity --reset (below) tells another story.

I'd be glad to know how to fix those errors:

WARNING: Unity currently default profile, so switching to metacity while resetting the values
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Initializing core options...done
compiz (core) - Warn: failed to receive ConfigureNotify event on 0x2400004

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x1400002

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x1600002

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x40000dd

Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing vpswitch options...done
Initializing snap options...done
Initializing mousepoll options...done
Initializing resize options...done
Initializing place options...done
Initializing move options...done
Initializing wall options...done
Initializing grid options...done
Initializing session options...done
Initializing gnomecompat options...done
Initializing animation options...done
Initializing fade options...done
Initializing unitymtgrabhandles options...done
Initializing workarounds options...done
Initializing scale options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing ezoom options...done

(compiz:5391): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed
error subscribing to gestures
WARN  2014-01-04 16:14:47 unity.favorites FavoriteStoreGSettings.cpp:139 Unable to load GDesktopAppInfo for 'ubiquity-gtkui.desktop'
compiz (unityshell) - Error: GL_ARB_vertex_buffer_object not supported

X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  33 (X_GrabKey)
  Serial number of failed request:  6214
  Current serial number in output stream:  6460
share|improve this question
    
Tried solutions for the same problem under 13.04, didn't work cause of purge fglrx errors and gsettings no actual scheme. Keep in mind that fglrx worked fine with 12.04 for a long time, I got a problem only recently. –  Esamo Jan 4 at 20:48

1 Answer 1

up vote 0 down vote accepted

Worked for me (fixed Unity system bar and launcher):

Reinstall all already installed packages in Synaptic related to searches libgl and glx.

May be needed first:

sudo apt-get purge fglrx fglrx-amdcccle    # or another fglrxs

But FGLRX drivers doesn't feel alright on my computer anymore, so goodbye FGLRX :( . No idea why.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.