Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello when i create an instance in openstack dashboard and try to allocate an ip address i see :

Error: 404-{u'NeutronError': {u'message': u'External network a522b82c-7640-4108-8bdb-72e6218aace7 is not reachable from subnet ce361cbe-9e1b-46a3-aa27-5ab6e757cf82. Therefore, cannot associate Port b8caff6b-e2cc-4a1f-8cb3-bf06c583ea8b with a Floating IP.', u'type': u'ExternalGatewayForFloatingIPNotFound', u'detail': u''}} × Error: Unable to associate IP address

I have one MAAS server and two nodes in it. My network is :

213.149.x.x ==> ==> ==> MAAS + NODE + NODE

Can you give me an advice how should my network toplogy look like ? Thanks!

share|improve this question

Thank you for the report!

This is a confirmed bug in juju-core, which you helped discover:

It basically means Juju's OpenStack provider is not yet compatible with versions of OpenStack later and including Grizzly (in certain cases). Since part of the current development emphasizes on more customizable networking and better addressability between entities across a Juju environment, your issue is considered a regression and is highly likely it will be fixed in the next stable Juju release (1.18.0).

In the mean time, you could manually or through the OpenStack command-line clients reproduce the suggested fix:

  • Instead of 2 separate subnets with netmask /24, create them with mask /16.
  • This way with sufficiently recent OpenStack (likely at least Havana: see here) you could create a router, gateway, assign one to the other and make sure all of them fit in the same /16 netmask. This way you enable floating IP assignment with sequential exhaustion (pick the next available going over and translating to each subnet's IP address).
  • See also
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.