Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu touch on my Nexus 7.

Unfortunately I can't install anything from the terminal app:

If I enter:

sudo apt-get install yasm -y git make g++ build-essential libminiupnpc-dev

I get:

W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened.

If rebooted the device & googled but wasn't successful yet.

Can anyone help me please?

Thanks!

share|improve this question
    
Can you add lsblk to your question? Also, you can try sudo mount -o remount,rw / –  minerz029 Jan 3 at 21:32
    
It works! Thank you! –  Clipper Dashing Wave Jan 3 at 21:42
    
Clipper, it would be great if you could add the solution as an answer and accept it to move this out of unanswered. –  Julian Stirling Jan 3 at 21:47
    
@JulianStirling Unfortunately I can't answer to my own questions. "Users with less than 10 reputation can't answer their own question for 8 hours after asking. You can answer 1/4/2014 5:29:31 AM. Until then please use comments, or edit your question instead." Also I don't now how to move it out of unanswered. Can you help me? The solution was sudo mount -o remount,rw / –  Clipper Dashing Wave Jan 3 at 21:56
2  
You can accept my answer in 10 mins. I feel like I am "stealing" the reputation though :( –  Julian Stirling Jan 3 at 22:01

1 Answer 1

up vote 5 down vote accepted

The answer is:

sudo mount -o remount,rw /
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.