Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to run the "Start Terminal Here" command I get Error executing

konsole --workdir %d!

On the net I found that the reason is that I have konsole is not installed, but I don't have root and I can't install here anything. I tried putting

sh

bash

gnome-terminal

but the console is not being shown and nothing happens, what can I do?

I want to start terminal from cuurect location opened in Krusader

share|improve this question
1  
krusader is a kde app and gnome-terminal a gnome app so please add the OS version you use (kde/gnome?). Might be relevant to commands you issue on command line. –  Rinzwind May 4 '11 at 10:04

7 Answers 7

up vote 0 down vote accepted

Terminal (Konsole) starts in Applications | System . Try to run the terminal outside krusader, this will tell you if it's a larger problem than krusader.

In krusader; [settings | configure krusader ]

Under General;

konsole --workdir %d

and under User Actions

konsole --noclose --workdir %d --title %t -e
share|improve this answer
    
I did it, but the error remains. –  Alex Malex Mar 9 '13 at 8:46
    
that doesn't work. –  Alex Apr 19 at 11:16

Go to System Settings panel, there, in "Default Application" you can set you preferred console app.

share|improve this answer

gnome-terminal --working-directory %d

share|improve this answer
    
Some explanation? –  Joren Oct 4 '13 at 11:17
    
in Krusader menu -> Settings -> Configure Krusader... -> Tab "General" -> Terminal: gnome-terminal --working-directory %d –  Andy Oct 4 '13 at 18:28
    
or in Mint Mate: mate-terminal %d –  Andy Oct 4 '13 at 18:29
    
Press F2 or Left-Bottom Button to call Terminal –  Andy Oct 5 '13 at 8:27

Ahoi Together,

looks like you forgot to install the konsole package. Try this:

sudo apt-get install konsole

Kind regards,
T.A.O.

share|improve this answer

Control+alt+F1 wil show you a console login. Use your user account and password to login and issue the install command from there.

(With Control+alt+F7 you will go back to your desktop).

share|improve this answer

Thank you so much, I've looked into your forum's discussion, I had the same problem, I've installed konsole package by doing sudo apt-get install konsole and konsole terminal appeared exactly inside the directory where I clicked to bring up konsole.

share|improve this answer

To use Konsole (KDE terminal):

sudo apt-get install konsole


To use Gnome terminal - alter Krusader settings:
Under General

gnome-terminal --working-directory %d

Under User Actions

gnome-terminal --working-directory %d --name %t -e

To emulate Konsole --noclose parameter in Gnome terminal - open a new gnome-terminal, navigate to Edit -> Profile settings. Click on the "Title and Command" tab. Change "exit the terminal" to "hold the terminal open".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.