Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello i have problem with install ati 13.12 drivers on kubuntu 13.10. I receive this error in console

    Loading new fglrx-13.251 DKMS files...
Building only for 3.11.0-15-generic
Building for architecture x86_64
Building initial module for 3.11.0-15-generic
Error! Bad return status for module build on kernel: 3.11.0-15-generic (x86_64)
Consult /var/lib/dkms/fglrx/13.251/build/make.log for more information.
update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up fglrx-amdcccle (2:13.251-0ubuntu1) ...
Setting up fglrx-dev (2:13.251-0ubuntu1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.11.0-15-generic
^Cdpkg: error processing initramfs-tools (--install):
 subprocess installed post-installation script was interrupted
Processing triggers for libc-bin ...
Errors were encountered while processing:
 initramfs-tools

This is /var/lib/dkms/fglrx/13.251/build/make.log

DKMS make.log for fglrx-13.251 for kernel 3.11.0-15-generic (x86_64)
пт яну  3 21:04:01 EET 2014
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.11.0-15-generic/build SUBDIRS=/var/lib/dkms/fglrx/13.251/build/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-3.11.0-15-generic'
  CC [M]  /var/lib/dkms/fglrx/13.251/build/2.6.x/firegl_public.o
  CC [M]  /var/lib/dkms/fglrx/13.251/build/2.6.x/kcl_acpi.o
/var/lib/dkms/fglrx/13.251/build/2.6.x/kcl_acpi.c: In function ‘KCL_ACPI_ParseTable’:
/var/lib/dkms/fglrx/13.251/build/2.6.x/kcl_acpi.c:999:5: warning: passing argument 1 of ‘(acpi_status (*)(u32,  void *, void *))handler’ makes integer from pointer without a cast [enabled by default]
     ((acpi_table_handler)handler)(hdr);
     ^
/var/lib/dkms/fglrx/13.251/build/2.6.x/kcl_acpi.c:999:5: note: expected ‘u32’ but argument is of type ‘struct acpi_table_header *’
/var/lib/dkms/fglrx/13.251/build/2.6.x/kcl_acpi.c:999:5: error: too few arguments to function ‘(acpi_status (*)(u32,  void *, void *))handler’
make[2]: *** [/var/lib/dkms/fglrx/13.251/build/2.6.x/kcl_acpi.o] Error 1
make[1]: *** [_module_/var/lib/dkms/fglrx/13.251/build/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.11.0-15-generic'
make: *** [kmod_build] Error 2
build failed with return value 2

I reinstall PC with format root and home partitions but problem is same. My video is Radeon HD5750

share|improve this question
    
Welcome to Ask Ubuntu. Please do not answer the question within the question. Put the answer below where it says Your Answer. Then you will be able to accept your answer as correct by putting the green check mark against it. Please to not put (solved) in the title. The green mark indicates the accepted answer. –  user68186 Jan 4 at 0:06

1 Answer 1

up vote 6 down vote accepted

I find this solution on google this working for me https://gist.github.com/moldcraft/8116528

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.