Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I enter the command

sudo dpkg -i Fern-Wifi-Cracker_1.6_all.deb

this error come up

mohamed@mohamed-K55A:~/Downloads/aircrack-ng-1.2-beta2$ cd /home/mohamed/Desktop
mohamed@mohamed-K55A:~/Desktop$ sudo dpkg -i Fern-Wifi-Cracker_1.6_all.deb
Selecting previously unselected package fern-wifi-cracker.
(Reading database ... 211283 files and directories currently installed.)
Unpacking fern-wifi-cracker (from Fern-Wifi-Cracker_1.6_all.deb) ...
dpkg: dependency problems prevent configuration of fern-wifi-cracker:
 fern-wifi-cracker depends on aircrack-ng; however:
  Package aircrack-ng is not installed.
 fern-wifi-cracker depends on python-scapy (>= 2.0); however:
  Package python-scapy is not installed.
dpkg: error processing fern-wifi-cracker (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 fern-wifi-cracker

any solution

and when i enter the command sudo apt-get -f install this is come up
mohamed@mohamed-K55A:~/Desktop$ sudo apt-get -f install Reading package lists... Done Building dependency tree
Reading state information... Done Correcting dependencies... Done The following packages will be REMOVED: fern-wifi-cracker 0 upgraded, 0 newly installed, 1 to remove and 3 not upgraded. 1 not fully installed or removed. After this operation, 3514 kB disk space will be freed. Do you want to continue [Y/n]? y perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = "en_US:en", LC_ALL = (unset), LC_TIME = "en_US.UTF-8", LC_MONETARY = "en_US.UTF-8", LC_ADDRESS = "en_US.UTF-8", LC_TELEPHONE = "en_US.UTF-8", LC_NAME = "en_US.UTF-8", LC_MEASUREMENT = "en_US.UTF-8", LC_IDENTIFICATION = "en_US.UTF-8", LC_NUMERIC = "en_US.UTF-8", LC_PAPER = "en_US.UTF-8", LANG = "en_US.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory (Reading database ... 215040 files and directories currently installed.) Removing fern-wifi-cracker ... Processing triggers for desktop-file-utils ... Processing triggers for bamfdaemon ... Rebuilding /usr/share/applications/bamf.index... Processing triggers for gnome-menus ...
and i'm using (ubuntu 12.04 LTS)

share|improve this question
    
Have you installed aircrack-ng and python-scapy yet? The error message seems very clear to me. Running dpkg -i foo.deb will not automatically resolve the dependencies of foo.deb. You will need to install them yourself. –  dobey Jan 5 at 19:44

2 Answers 2

I would try the following:

sudo apt-get -f install

This will hopefully clear any issues with previous updates or installs.

share|improve this answer
    
not working at all –  sasuki131 Jan 3 at 19:22
    
do you get any message when you type this command in? –  cprofitt Jan 3 at 19:47
    
what version of Ubuntu are you using? –  cprofitt Jan 3 at 19:53
    
thanks i've been found sol. :) –  sasuki131 Jan 7 at 9:01
up vote 0 down vote accepted

I've been found the SOL. type in terminal:

user@user2343:~$svn checkout http://fern-wifi-cracker.googlecode.com/svn/Fern-Wifi-Cracker/
user@user2343:~$cd /home/user/Fern-Wifi-Cracker
user@user2343:~/Fern-Wifi-Cracker$ sudo python execute.py

but you should must install all files that fern-wifi-cracker that need it if dosent worked contact:[email protected]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.