Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I plug by digital camera in, a nice media-icon pops up. Great! !

When I right click on this icon, I can only open Rhythmbox or VLC-media-player. Both applications are rather senseless to be used here. When I want to download photos (be it by means of F-Spot, Shotwell or Picasa) I have to unmount the camera first. This seems to me rather illogical ? Why is the camera mounted if you have to unmount it to be used? How can I make that the digital camera is being mounted for the right applications? It looks strange to me that one has to unmount a device before one can use it!

Camera model : Canon PowerShot SX20 IS (new id has been added for this camera in libgphoto2 2.4.9. The packagemanager tells me that libgphoto2-2 is installed, version 2.4.8-0ubuntu2 => it looks like libgphoto2 can't read the camera? Anyway, the PTP/MTP- mode works fine)

uname -a
Linux Ubuntu-Bernard **2.6.32-24-generic #42-Ubuntu** SMP Fri Aug 20 14:24:04 UTC 2010 i686 GNU/Linux

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="**Ubuntu 10.04.1 LTS**"

lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 04a9:31e4 **Canon, Inc.** 
Bus 001 Device 003: ID 0b05:1706 ASUSTek Computer, Inc. WL-167G 802.11g Adapter [ralink]
Bus 001 Device 002: ID 050d:0234 Belkin Components F5U234 USB 2.0 4-Port Hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Type filesystem = **gphoto2**

KernelLoggings (plug-in/plug-out)
Sep 11 19:23:55 Ubuntu-Bernard kernel: [ 1370.156803] usb 1-2.1: new full speed USB device using uhci_hcd and address 4
Sep 11 19:23:55 Ubuntu-Bernard kernel: [ 1370.282419] usb 1-2.1: configuration #1 chosen from 1 choice
Sep 11 19:31:59 Ubuntu-Bernard kernel: [ 1854.101144] usb 1-2.1: USB disconnect, address 4


Detailled Camera info
lsusb -v

Bus 001 Device 007: ID 04a9:31e4 Canon, Inc. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x04a9 Canon, Inc.
  idProduct          0x31e4 
  bcdDevice            0.02
  iManufacturer           1 Canon Inc.
  iProduct                2 Canon Digital Camera
  iSerial                 3 E2F5E9B80A584FFDA901B46ECBC87410
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower                2mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
          bInterfaceClass         6 Imaging
      bInterfaceSubClass      1 Still Image Capture
      bInterfaceProtocol      1 Picture Transfer Protocol (PIMA 15470)
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              32
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0001
  Self Powered
share|improve this question
    
Hi Bernard, we'll need a little more information. What model is the camera, what is the output of lsusb when it is plugged in, and what version of Ubuntu are you using? Thanks! –  ændrük Sep 10 '10 at 22:14
add comment

2 Answers

I think you can handle this through the Nautilus preferences.

  1. Open Nautilus (Places -> Home Folder).
  2. Click the Edit drop down menu.
  3. Choose Preferences.
  4. In the File Management Preferences window, click the Media tab.
  5. The Media Handling section should allow you to configure the system to behave the way you want when you attach the camera.[1]

[1] The options next for Photos, include: Ask what to do, Do Nothing, Open Folder, Open F-Spot, Open with other Application...

share|improve this answer
    
Thank you for your advice, Jim. Changing the option next to Photos didn't help. However if I change the option musicplayer to be opened with eg. Shotwell Photomanager, then Shotwell is started! This means that a gphoto2-medium is considered as one of a musicplayer! However, the medium must be unmounted before Shotwell can use it. So changing these options does not solve the mount-problem. –  Bernard Decock Sep 23 '10 at 16:13
    
This doesn't work for me in precise 12.04 - I don't see Media Handling in Nautilus prefs. Nor do I find such settings in the System Settings window. But typing "media" in the unity dash finds something just called "Details" with a "removable media" section that lets me do this. –  nealmcb Jun 8 '12 at 21:25
add comment

Just a stab in the dark, but if you temporarily comment out the following lines in /lib/udev/rules.d/45-libmtp8.rules, does it help at all?

  • # Canon PowerShot SX20IS (PTP/MTP mode)
    # ATTR{idVendor}=="04a9", ATTR{idProduct}=="31e4", SYMLINK+="libmtp-%k", MODE="660", GROUP="audio"
    
  • # Canon PowerShot SX20IS (PTP/MTP mode)
    # ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="31e4", SYMLINK+="libmtp-%k", MODE="660", GROUP="audio"
    
share|improve this answer
    
Thanks a lot ændrük for your advice. I changed the rules, but i didn't help me any further. I googled around and found that this issue has (or is?) a bug. See ubuntuforums.org/archive/index.php/t-1193340.html ubuntuforums.org/showpost.php?p=7205851&postcount=4. –  Bernard Decock Sep 15 '10 at 17:34
    
sudo chmod -x /usr/lib/gvfs/gvfs-gphoto2-volume-monitor helps, but the camera-icon is no longer shown on the desktop. If the volume-monitor was allowed to run, you got gphoto2 --list-files "Error initializing camera: -60: Could not lock the device". I think I better file a bug in launchad? –  Bernard Decock Sep 15 '10 at 17:42
1  
This problem was filed as a bug in 2008: camera automount prevents import : bugs.launchpad.net/ubuntu/+source/gvfs/+bug/196757 –  Bernard Decock Sep 21 '10 at 18:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.