Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Just bought a Geforce GTX 660 and replaced my Radeon HD 5870 (it finally died after 3 years). I'm having terrible problems getting the video card to work. As I only had command line options so far I've ran: (purged fglrx*)

then

sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update sudo apt-get install nvidia-331

and then I started getting low graphics mode errors. did some searching on my tablet, and I tried several things but what finally worked better was:

sudo apt-get install bumblebee bumblebee-nvidia

However now that I'm logged into my computer finally, I have no access to terminal, no access to the top bar, and hitting Super Key does nothing, alt-f2 does nothing, and I only can post because I tried running WoW and it had an error and the error report opened a link.

All I can see on my desktop is my wallpaper and desktop icons. I can CTRL+ALT+F1, and navigate to the downloaded official nvidia driver, however that won't run because of x-server, and I can't run it from my desktop.

Can anyone help me?

share|improve this question

marked as duplicate by Luis Alvarado Mar 29 at 17:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Just a word of advice - do not use xorg-edgers ppa with this card. I just have recovered from major crash with exactly same hardware configuration. X-spat may be better choice, I have not experienced any difficulties here. –  MateuszS Jan 4 at 21:50
    
Marked as duplicate of one that will actually solve your problems. Specially now that correct drivers are available for it and there is no need to manually update them every time a kernel changes. –  Luis Alvarado Mar 29 at 17:42

2 Answers 2

Executing sudo apt-get install nvidia-current should make it.

Please note that the nvidia-current package is located in the restricted repository. If the package is not found. Edit the /etc/apt/sources.list file, and remove the leading # character, of the following line

#deb http://de.archive.ubuntu.com/ubuntu/ saucy main restricted

Save the file and execute sudo apt-get update && sudo apt-get install nvidia-current.

It should work

share|improve this answer
    
I tried that among many of my attempts, and that did not work. –  Michaeljwjr Jan 6 at 1:41
up vote -2 down vote accepted

Downloaded the official nvidia driver, then CTRL+ALT+F1. Logged in, then went to the Downloads directory and typed:

sudo service lightdm stop
sudo chmod a+x NVIDIA-*.run
sudo ./NVIDIA*.run
sudo reboot

as per: http://news.softpedia.com/news/How-to-Install-the-Latest-NVIDIA-331-20-Drivers-in-Ubuntu-13-10-399182.shtml

share|improve this answer
    
And now you have to repeat this procedure every time kernel or anything upgrades. –  Barafu Albino Mar 29 at 17:28
    
@BarafuAlbino I have a script that does it so it's no problem for me ;) –  Michaeljwjr Mar 29 at 22:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.