Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I originally got internet service my ethernet port was not turned on. Found this thread How do I install drivers for the Atheros AR8161 Ethernet controller?, followed directions under answer 1 and it enabled my ethernet port. Now, the problem is that every time I disconnect the ethernet cable or restart my computer, I have to go through the process all over again to enable my ethernet port. How do I make this change permanent so that my ethernet port remains on? I'm running Xubuntu 12.04 64-bit.

share|improve this question
    
Is it the modprobe ... command that you have to run? –  Wilf Jan 3 at 14:37
    
I have to run all of the commands in order to get it to function each time. –  Jason Smith Jan 3 at 14:38
    
You mean you have to reinstall it every time? :-s –  Wilf Jan 3 at 14:39
    
Seems to be the case. Just running 'sudo modprobe alx' alone doesn't seem to work. –  Jason Smith Jan 3 at 14:42
    
Are you referring to this answer - once it is installed, it should stay installed. Also, please add the output of sudo apt-get install linux-backports-modules-cw-3.4-precise-generic command. –  Wilf Jan 3 at 14:44
show 2 more comments

1 Answer 1

Try:

echo alx | sudo tee /etc/modules

This will add the module to the /etc/modules file, so it loads automatically, and so you don't have to run the sudo modprobe alx command every time.

share|improve this answer
    
I got the following error when running this command and tried running it with sudo and got the same error message: bash: /etc/modules: Permission denied –  Jason Smith Jan 3 at 14:51
    
Whooops... changed answer ;-) –  Wilf Jan 3 at 14:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.