Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I type "google.com" or "http://google.com" into the address bar in Firefox I end up with the following screen requesting some login and password.

Firefox requesting password at google.com

When I try the same in Chrome or Opera, I get redirected to www.google.com or www.google.pl. I killed dnsmasq and in /etc/hosts there's nothing similar to google.com.

When I press Cancel, I get the following error 401 message.

error 401

What is going on? Is it a virus? But why is it active only for Firefox?

Any help will be highly appreciated!

I use an up-to-date Ubuntu 12.04 with Firefox 26.0.

Update: I first noticed the problem, when I lost my internet connection (I mean formally there was a connection, but there was no or hardly any transfer) without any reason (the first thing I did was typing google to check if it is a problem with a single domain or the whole connection).

I just tried the same on another machine with similar configuration (my current Ubuntu was cloned from that a few months ago) and everything is OK...

share|improve this question
    
That's odd. This is a stab in the dark, but in Firefox, can you go to Edit > Preferences > Advanced > Network, and click Settings... under Connection? Are there any proxy settings there? –  Alaa Ali Jan 3 at 13:12
    
@Alaa Perfect guess! It was 'Use system proxy settings' and after switching to 'No proxy' it is fine - I mean, I get redirected to www.google.pl. But it doesn't explain the root cause of the problem. Do you think there is something wrong about my router? –  savick01 Jan 3 at 16:18
    
No, it's not your router. We have to look at what does "Use system proxy settings" do in Firefox. I don't normally use Firefox, but I think that option tells Firefox to use whatever proxy the operating system is using (i.e what you have configured in the Proxy settings in Ubuntu). But all of this is odd because that means that you have your router configured as the proxy...but why are Chrome and Opera working =)? Are you using a proxy anyways? Search and open "Network" in the Ubuntu Dash, and check the Network proxy settings. Are they set to anything? –  Alaa Ali Jan 4 at 14:09
    
I've added my first comment as an answer to your question. –  Alaa Ali Jan 4 at 14:09
    
@Alaa I don't think I use proxy in Ubuntu. In System Settings > Network > Network proxy the chosen Method is None. Btw. Chrome says 'Google Chrome is using your computer's system proxy settings to connect to the network' and it is not configurable. And Firefox after choosing 'No proxy' instead of 'Use system proxy settings' works fine. –  savick01 Jan 4 at 14:30

1 Answer 1

Check the proxy settings on Firefox.

To do so in Firefox, go to EditPreferencesAdvancedNetwork, and click Settings... under Connection. If you aren't using a proxy, set it to No proxy, or enter in your correct proxy settings if you're using one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.