Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the upstart-job for Teamviewer 9. According to the config it should start when dbus and lightdm is running, see:

start on (
              (started dbus         or
               started init-system-dbus)
              and
             (
              starting-dm           or
              started gdm           or
              started kdm           or
              started lightdm       or
              started lxdm          or
              started prefdm        or
              started xdm)
            )

As you can see, both are started here on my Ubuntu 13.10 but teamviewerd does not start automatically:

root@surf:~# initctl list |grep dbus
dbus start/running, process 807
root@surf:~# initctl list |grep lightdm
lightdm start/running, process 2336
root@surf:~# initctl list |grep teamviewerd
teamviewerd stop/waiting

In the log I get (after a reboot):

root@surf:~# cat /var/log/upstart/teamviewerd.log
method return sender=org.freedesktop.DBus -> dest=:1.6 reply_serial=2
   uint32 1

If I start it manually it works as expected:

root@surf:~# initctl start teamviewerd 
teamviewerd start/running, process 13796

What is wrong with this job?

share|improve this question

1 Answer 1

There are some integrated deamon commands in teamviewer. At least on 8th version.

teamviewer --daemon status           show current status of the TeamViewer daemon
teamviewer --daemon start            start                      TeamViewer daemon
teamviewer --daemon stop             stop                       TeamViewer daemon
teamviewer --daemon restart          stop/start                 TeamViewer daemon
teamviewer --daemon disable          disable                    TeamViewer daemon - don't start daemon on system startup
teamviewer --daemon enable           enable                     TeamViewer daemon - start daemon on system startup (default)

source

share|improve this answer
    
Correct, i used 'enable' to create this upstart-job. But it doesn't start automatically anyhow. –  Florian Lagg Jan 3 at 12:19
    
Did you used with root privileges, correct ? Maybe you have to communicate with the teamviewer team and inform them. –  NikTh Jan 3 at 12:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.