Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed Ubuntu 13.10 as the primary OS on my laptop. I installed Windows 8 in another partition and set up GRUB to be the boot loader. Eventually I updated Windows and it became a black screen so I reinstalled Windows in that partition. Somehow doing this removed Windows from GRUB's menu and so I tried to reinstall GRUB which I had a little trouble doing. I tried it a few different ways, one of them was booting from a LiveCD and involved mounting and unmounting things (did this pretty much blindly as I don't have a lot of the know how). That didn't work but I came across the standard boot-repair program and it worked fine.

The big problem I have no is that Ubuntu does not load after selecting it from GRUB. It just hangs at a black screen. When I select recovery mode, it goes to the menu. When I resume the normal boot, it reads out:

Ubuntu 13.10 Denjay-Laptop tty1

Denjay-Laptop login:_

With a flashing underscore. After a few seconds it then adds to that line initct1: Event failed

I also checked all the file systems with the recovery mode and with a LiveCD and nothing was anomalous on that end. I've also gone through updating GRUB so I think something wrong post-GRUB if that makes sense.

I heard that it might be a video card problem so I tried nomodeset which still resulted in a black screen. One user had too many drivers installed on their card and they input dpkg --get-selections nvidia-* to show their drivers. My laptop has "amd a8 3520m apu with radeon tm hd graphics" and I'm not sure what the driver package name for that is. So what should I replace nvidia with for to get the driver?

Any help would be greatly appreciated.

share|improve this question
    
Try lspci -nnk | grep -i vga -A3 | grep 'in use' (askubuntu.com/questions/23238/…) –  Jeremy Jan 2 at 21:56
    
That returned Kernel driver in use: fglrx_pci –  Denjay Jan 2 at 22:26
    
So try dpkg --get-selections flgrx* –  Jeremy Jan 2 at 22:30
    
And that returned fglrx deinstall; fglrx-amdcccle-updates install; fglrx-updates install –  Denjay Jan 2 at 22:34
    
Try following the answer here: askubuntu.com/questions/78906/… –  Jeremy Jan 2 at 22:46
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.