Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a server running Ubuntu Server 11.04, and when I add a PPA via add-apt-repository, apt-get doesn't load the PPA when I do apt-get update. It's specifically this PPA I need to add, but same thing happens for all the PPA's I've tried.

I have checked that the .list files are in fact created in /etc/apt/sources.list.d/, and if I add the PPAs' "string" directly in to /etc/apt/sources.list, it still doesn't work.

You can see here in action that I first add the PPA and then update, but the PPA's is not on the list of loaded archives. I have also done a s-trace something, that some guy on #ubuntu-server said I could try, and the PPA's I add are actually shown in it and "handled", but for some reason, they are still not getting "punched in use".

I hope somebody can help me with this.

By the way, this server is originally a 10.04.1 installation that has been upgraded to 10.10 and then to 11.04, if that can have something to do with it.

Thank you so far, ChrisBuchholz

share|improve this question
    
Link to the s-trace something: paste.ubuntu.com/602496 –  chrisbuchholz May 4 '11 at 5:48
    
indeed the ppa is empty but you could use the 10.10 packages, in the meantime, i don't think that it would crash the OS... –  Uri Herrera May 4 '11 at 9:06
add comment

3 Answers

up vote 1 down vote accepted

I would guess that if the natty ppa is empty you will have to change it to maverick To get it to work.
You can also check the ppa's web site for what they have available.

share|improve this answer
add comment

http://ppa.launchpad.net/jerome-etienne/neoip/ubuntu/dists/natty/main/binary-i386/Packages is empty so there aren't any binary packages for 11.04 in this PPA

share|improve this answer
add comment

What makes you think the PPA is not loaded?

I just added the PPA and during the apt-get update there is no specific reference to the PPA.

If you change the path and add some random characters in the .list file, do you get any errors during the apt-get update

share|improve this answer
    
Well, alright. So I guess thats possible. But what makes me believe it's not loaded ultimately, is that I can't download the package. If I install the package nodejs, I get version from the ubuntu 'universe' archive. ´apt-cache show nodejs` also tells me that, thus, it seems like the package from PPA is not "punched in use". And yes, if I add some "random characters" to the .list file, apt-get update does indeed fail. –  chrisbuchholz May 4 '11 at 9:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.