Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop running Ubuntu 13.04 which drives a monitor in the hallway in our office. I use a scheduled task to turn the monitor on and off each day when people are out of the office. At the end of the day, a scheduled task runs "xset dmps force standby" and first thing in the morning another task runs "xset dpms force on".

The problem I have is that every morning we come in and the monitor is on, but it's just showing a blank (solid black) screen. I have to remote desktop into the machine to really wake up the screen.

These commands work great when I just run them to test. For example, if I run the following from the commandline "xset dpms force standby && sleep 5 && xset dpms force on", I see exactly the behavior I want. The screen goes to sleep, waits 5 seconds, and then wakes up. It's just when the machine actually sits over night that it fails.

I've tried telling the screen not to blank everywhere I could find (i.e. the xscreensaver-demo UI, the Power, and Lock options). I also checked "xset q" and it looks like the dpms values there are all set to 0.

Is there any way for me to figure out what is blanking my screen?

share|improve this question
    
Try using xset dpms force off. The monitor will still be powered though, so you can't you use the OFF button? :-) –  Wilf Jan 2 at 18:58

1 Answer 1

Suggest you have your evening task run xset dpms 10 20 0 which hits standby in 10 seconds, hits suspend after 20 seconds, and won't drop into OFF mode, which is where I think your problem lies.

share|improve this answer
    
Thanks, but when I run "xset q" it tells me that DPMS is already 0 0 0. So I don't think that's the problem. Or it's lying to me. That's why I'm looking for a way to log what program is blanking the screen. –  jared Jan 2 at 21:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.