Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my Maverick to Natty 3 days ago. It's fun and good. I try to be familiar with Unity, but the Natty constantly freezes suddenly. I try another alternative, I use Ubuntu Classic instead of Unity, and at the end my computer continues freezing suddenly and it made me really angry, I can't do anything except of force my computer to shut down through the power button. My laptop is Compaq CQ20 windows & 32bit

share|improve this question
    
do you have any propietary drivers installed? –  Uri Herrera May 4 '11 at 4:57
    
of course, I already installed the drivers through "Additional Driver" at system menu –  ok comp May 4 '11 at 5:01
    
most likely is that, are they nvidia or ati? uninstall them and keep the nouveou or radeonHD drivers a.k.a the open source one's –  Uri Herrera May 4 '11 at 5:03
    
i only have integrated graphic card. –  ok comp May 4 '11 at 5:38
    
intel integrated graphics? 'cause there's amd too... –  Uri Herrera May 4 '11 at 5:57
show 3 more comments

3 Answers

up vote 1 down vote accepted

Add this to your repositories.

     deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu natty main #xorg-edgers PPA                  
    deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates natty main #xorg-edgers PPA

or in the terminal:

     sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

or Open the Software Sources menu by going to Applications->Ubuntu Software Center, then selecting Edit->Software Sources. Choose the Other Software tab and click Add.

     ppa:ubuntu-x-swat/x-updates

and then

     sudo apt-get update

see if it helps.

share|improve this answer
1  
You advise a supposedly non-guru user to upgrade to non-default X ? I wouldn't recommend that. –  Barafu Albino May 4 '11 at 8:22
    
it's not that hard.. clicking the ubuntu logo, and go to software sources and add the ppa.. it's pretty straight forward? –  Uri Herrera May 4 '11 at 8:27
    
or opening a terminal and typing the ppa to add it –  Uri Herrera May 4 '11 at 8:34
    
and why not? the present state the drivers he's using are causing that if he updates them he's most likely to get it fixed. –  Uri Herrera May 4 '11 at 8:36
1  
Xorg-edgers is not for the faint of heart - it's populated with automated builds of upstream development. There's no guarantee those packages will work at all. –  RAOF May 4 '11 at 9:16
show 1 more comment

Besides Uri answer try this too: enable proposed updates in Software Sources, and update your system to 2.6.38-9 kernel. Maybe this helps.

share|improve this answer
    
thanks for your feedbacks, but I get confused of too many answers given, can you give me the straight forward answer? –  ok comp May 6 '11 at 3:29
add comment

I have an HP MINI 210 and it freezes like yours, my issue? the wireless card!

the solution: blacklisting the following drivers:

blacklist rt2800pci
blacklist rt2800lib
blacklist rt2x00usb
blacklist rt2x00pci
blacklist rt2x00lib

(this should be appended to the file /etc/modprobe.d/blacklist.conf)

then restart and it should be working if this is your issue!

if this doesn't work, don't forget to remove those lines from the file.

good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.