Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 and it's kernel version is "3.8.0-29-generic". For learning purposes I want to change my kernel version from 3.8.o to 3.5.0 version, but I am unable to install it in Ubuntu 12.04.

I followed these steps for kernel compilation:

After downloading source code from kernel.org i followed these steps:

  1. tar -xvf linux-3.5.tar.xz
  2. cd linux-3.5/
  3. ls
  4. make menuconfig
  5. make -j
  6. make modules_install
  7. sudo make modules_install
  8. sudo make install
  9. make modules
  10. sudo reboot

After successful completion of all these steps, Ubuntu is again starting with kernel 3.8.0 generic version. How can I change it?

share|improve this question
    
When you reach the stage with the GRUB2 menu, is there a choice for the older kernel? Please advise. –  K7AAY Jan 2 at 18:09
    
The grub menu is not displaying anything.after i typed the command "sudo reboot " it defaultly taking the 3.8 version and it not showing anything. –  Narasimha Reddy Jan 2 at 18:16
    
You could always try installing Ubuntu 12.10, I think that had 3.5 kernel by default... –  Wilf Jan 2 at 18:20
    
For learning purposes you mean compile your own kernel or you just need/want 3.5 kernel? –  xangua Jan 2 at 18:40
    
i want kernel 3.5 –  Narasimha Reddy Jan 3 at 3:23
add comment

4 Answers 4

up vote 0 down vote accepted

To reach the grub menu and see alternate kernels, hold down the Shift key at boot time. Go to the "Advanced options for Ubuntu" menu.

Also keep in mind that there are official mainline Ubuntu kernels you can install with dpkg.

share|improve this answer
add comment

Suggest amending your GRUB2 menu to add the option for the alternate kernal. Specific instructions are provided at How can I repair grub? (How to get Ubuntu back after installing Windows?) so you may add the older kernel.

share|improve this answer
add comment

Open a terminal and run:

sudo nano /etc/default/grub.cfg

and comment out this line:

GRUB_HIDDEN_TIMEOUT="0"

to:

#GRUB_HIDDEN_TIMEOUT="0"

This will mean that the menu will show by default, for the time in seconds defined by GRUB_TIMEOUT

You might want to change the timeout to this so that it automatically selects the default entry after 5 seconds:

GRUB_TIMEOUT="5"

So that it remembers the last selected entry, add in this line:

GRUB_SAVEDEFAULT=saved

and change GRUB_DEFAULT to:

GRUB_DEFAULT=saved

after making any changes, save with Ctrl+O and Enter, and exit with Ctrl+X.

Then run this to update the changes - this will also scan /boot for any new kernels, like the one you installed:

sudo update-grub

More on editing grub.cfg here

share|improve this answer
    
You need a space after the nano - sudo nano /etc/default/grub.cfg –  Wilf Jan 2 at 18:48
    
after typed the 1st command it displays a blank screen.how to i change the text GRUB_HIDDEN_TIMEOUT="0" to: #GRUB_HIDDEN_TIMEOUT="0" –  Narasimha Reddy Jan 2 at 18:56
    
For recent versions of GRUB, the config file should be at /etc/default/grub. If you have Grub1, try using /boot/grub/menu.lst instead, though I think that use different parameters... –  Wilf Jan 2 at 19:06
add comment

To install the Quantal hardware enablement packages in Precise, please run the following command:

sudo apt-get install --install-recommends linux-generic-lts-quantal xserver-xorg-lts-quantal libgl1-mesa-glx-lts-quantal

Source: https://wiki.ubuntu.com/Kernel/LTSEnablementStack

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.