Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony Ericsson Xperia Arc phone and I cannot access its SD card through the USB cable provided.

I have set the USB connection mode to MSC yet when I connect the phone to my computer I cannot see the SD card (or anything for that matter).

The Disk Utility however, does see an SEMC Mass Storage device but it says that no media was detected.

I have validated that the SD card works as I removed it from the camera and plugged it into a card reader and saw all the photos and files stored on it.

I have validated that the phone works as I have connected it (in MSC mode) to my wife's Windows 7 computer.

Can anyone please tell me how I can access the SD card on my phone.

share|improve this question
add comment

3 Answers

I have a Xperia Sony Live with Walkman phone and i upgraded it into ICS 4.0 using official ROM.
I has same problem and i found answer...
You must set connectivity mode of your phone into mass storage mode (MSC). You can found this option through "Settings > Xperia > Connectivity > USB CONNECTION MODE > Change the option from MTP to MSC"
Please notice that your phone must be disconnected when you want to change that setting.

(I have an updated Ubuntu 11.10, 64-bit)

Good luck - Mousavi

share|improve this answer
add comment

Here's what you need to do:

(Before you do this, take note that apps that were moved to SD will disappear as the SD card needs to be unmounted!!!)

To mount:

  1. Connect the device via usb
  2. Go to notification, Set the USB connection mode to MSC (SEMC should pop up)
  3. Again in notification > connect phone memory card (this step will unmount your SD card).
  4. Wait until the notification in the device tells you that the phone memory card is connected. After that, the SEMC storage can now be accessed.

To unmount:

  1. Go to notification > phone memory card connected > disconnect
  2. Wait till a notification is received, your apps should return as usual

Hope this helps!

share|improve this answer
add comment

I had the same problem

with this widget

http://jaumard.android.free.fr/widgetsoid/?lang=fr_FR

"usb mount"

I see the sdcard in ubuntu 11.04

comment accéder à sa carte mémoire sd card - résolu - solved

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.