Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to connect to the internet via ethernet or wifi. Let's fix the ethernet issue, eh? I just installed Unbuntu 12.04 on an HP Mini 1000. Previously it had 11.04, and the ethernet didn't have any issues then. I am a linux beginner, and I have been working on this issue for the past several days without any progress.

Here are some outputs:

sudo lshw -C network

*-network               
   description: Network controller
   product: BCM4312 802.11b/g LP-PHY
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=b43-pci-bridge latency=0
   resources: irq:16 memory:feafc000-feafffff
*-network
   description: Ethernet interface
   product: 88E8040 PCI-E Fast Ethernet Controller
   vendor: Marvell Technology Group Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth0
   version: 00
   serial: 00:25:b3:48:e7:60
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
   resources: irq:42 memory:febfc000-febfffff ioport:ec00(size=256)

lspci

00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated     Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller

Thanks for your help!

share|improve this question
    
try going to "software and updates" (from the dash) then go to the tab where there are proprietary drivers; if you find any that are disabled enable them. –  Mina Michael Jan 2 at 2:41
    
Unfortunately, this screen doesn't show any available proprietary drivers since I do not have a network connection. –  ricky Jan 2 at 15:37

3 Answers 3

Found the solution:

In /etc/NetworkManager/NetworkManager.conf, I changed managed=false to managed=true. Then

sudo service network-manager restart

and voila.

share|improve this answer

sometimes NetworkManager can be a bit of a diva, and start messing with things you don't want it to. Try to take the mac address of the physical device you want to connect with ifconfig wlan0 for your wireless device, or ifconfig eth0 for an ethernet device. Copy everything after HWaddr. Then edit /etc/NetworkManager/NetworkManager.conf You will need to edit it with super user privileges. Add

[keyfile]
unmanaged-devices=mac:<copied HWaddr>;

Then you can connect manually which is talked about here How do I connect to a WPA wifi network using the command line?

Good luck!

share|improve this answer
    
The link you sent me to requires me to install a package... which I can't do as I have no network connection. Also, I am unable to connect via wifi through terminal any other way as there is no logical name for my wlan card as you can see in my lshw -C network. –  ricky Jan 2 at 16:01

I've just spent 2 hours trying to get my network back using the Network Manager and the terminal. Guess what fixed it.....turning off the modem, unplugging it, replugging it and switching it back on again. You can see the IP address codes, dns etc reappear in the Network Manager window if you leave this open. I'm thinking this is a "static lock" issue which sometimes happens with my Sky tv box. Hope this helps someone

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.