Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a 10.10 ubuntu installation and upgraded to most recent 11.04. After the upgrade when I start the transmission the window appears but no components inside and after a while it becomes grey and the option to force quite appears.

share|improve this question
2  
Offtopic: I find Deluge a lot better than Transmission –  Ashfame May 4 '11 at 13:59
    
@Ashfame +1 for the suggestion I ll give it a try, i have tried azureus and the server version of μtorrent but wasn't really statisfied. –  topless May 10 '11 at 11:09
    
Offtopic? Please, try Deluge, qTorrent (lighter), Flush (lightest) and see that they not have such issues. I am obsessed with the idea that people stay with Transmission just because it's default and think there must be a reason why. –  cipricus Mar 21 '12 at 16:55
    
How can default software of Ubuntu be off-topic? I stay with transmission because I don't care I just need some downloads, and it is there so I don't have to research about it and install extra stuff etc.. I agree that probably there are better tools out there, like always. And its a year ago and there was a way to fix it. A puzzle is always a challenge ;) help make good things, better! Cheers! –  topless Mar 21 '12 at 17:44

2 Answers 2

You could try reinstalling the Transmission packages you have installed:

dpkg -l | grep "ii  transmission" | sed -e 's/ii  //g' -e 's/ .*$//g' | xargs sudo apt-get install --reinstall

Command description: dpkg -l lists all the installed packages and sends the output to grep, which searches the list for transmission. sed then parses that and removes the description, package version, etc. so only the package name is shown. apt-get then reinstalls those packages.

share|improve this answer
up vote 1 down vote accepted

The problem solved by enabling the test ppa of transmission. It seemed to be transmission-gtk error.

sudo add-apt-repository ppa:transmissionbt/ppa

sudo apt-get update

sudo apt-get install transmission-common transmission-gtk
share|improve this answer
    
Where or how do you do that? Is that with synaptic ? –  user22931 Aug 8 '11 at 0:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.