Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded a Dell Precision M60 which uses a NVIDIA GPU Quadro FX Go1000 (NV36GL) graphics card from Ubuntu 13.04 to 13.10 today and now I cannot boot. Starting X flashes an NVIDIA logo briefly and then brings up a black screen and the keyboard is unresponsive - even CTRL + ALT + F1 to bring up a terminal login / window does not work.

I am using the nvidia-173 drivers (173.14.37-0ubuntu4) - nvidia-current does NOT work on this graphics card as it is not supported. An earlier driver present on 13.04, nvidia-173-updates, no longer appears to exist. I have followed instructions in other threads such as Ubuntu 13.04 - installation Nvidia driver and completely uninstalled all nvidia drivers and X, and reinstalled it. Same problem. I haven't followed instructions to install nvidia-current as I know this brings up a "not supported - use nvidia-173" message as follows

[   44.659 (WW) NVIDIA(0): The NVIDIA Quadro FX Go1000 GPU installed in this system is
[   44.659 (WW) NVIDIA(0):     supported through the NVIDIA 173.14.xx Legacy drivers.
[   44.659 (WW) NVIDIA(0):     Please visit http://www.nvidia.com/object/unix.html for
[   44.659 (WW) NVIDIA(0):     more information.   The 304.88 NVIDIA driver will ignore
[   44.659 (WW) NVIDIA(0):     this GPU. Continuing probe....    

The only way to recover is to boot into recovery mode and drop into a root shell prompt. I can access the laptop via ssh once X is loaded to do diagnostics. Running X remotely gets as far as running the NV_CONTROL module, then gives up

If I remove all nvidia drivers completely using apt-get remove --purge nvidia*, X picks up the VESA driver and boots into 640x480.

I don't have an xorg.conf present and the relevant bit of the most recent Xorg.0.log is as follows

[    50.717] (II) LoadModule: "glx"
[    50.717] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/libglx.so
[    51.064] (II) Module glx: vendor="NVIDIA Corporation"
[    51.064]    compiled for 4.0.2, module version = 1.0.0
[    51.064]    Module class: X.Org Server Extension
[    51.064] (II) NVIDIA GLX Module  173.14.37  Wed Mar  6 17:14:50 PST 2013
[    51.064] Loading extension GLX
[    51.064] (==) Matched nvidia as autoconfigured driver 0
[    51.064] (==) Matched nouveau as autoconfigured driver 1
[    51.064] (==) Matched vesa as autoconfigured driver 2
[    51.064] (==) Matched modesetting as autoconfigured driver 3
[    51.064] (==) Matched fbdev as autoconfigured driver 4
[    51.064] (==) Assigned the driver to the xf86ConfigLayout
[    51.064] (II) LoadModule: "nvidia"
[    51.064] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    51.065] (II) Module nvidia: vendor="NVIDIA Corporation"
[    51.065]    compiled for 4.0.2, module version = 1.0.0
[    51.065]    Module class: X.Org Video Driver
[    51.065] (II) LoadModule: "nouveau"
[    51.066] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    51.095] (II) Module nouveau: vendor="X.Org Foundation"
[    51.095]    compiled for 1.14.2.901, module version = 1.0.9
[    51.095]    Module class: X.Org Video Driver
[    51.095]    ABI class: X.Org Video Driver, version 14.1
[    51.095] (II) LoadModule: "vesa"
[    51.096] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    51.096] (II) Module vesa: vendor="X.Org Foundation"
[    51.096]    compiled for 1.14.1, module version = 2.3.2
[    51.096]    Module class: X.Org Video Driver
[    51.096]    ABI class: X.Org Video Driver, version 14.1
[    51.096] (II) LoadModule: "modesetting"
[    51.096] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    51.114] (II) Module modesetting: vendor="X.Org Foundation"
[    51.114]    compiled for 1.14.1, module version = 0.8.0
[    51.115]    Module class: X.Org Video Driver
[    51.115]    ABI class: X.Org Video Driver, version 14.1
[    51.115] (II) LoadModule: "fbdev"
[    51.115] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    51.117] (II) Module fbdev: vendor="X.Org Foundation"
[    51.117]    compiled for 1.14.1, module version = 0.4.3
[    51.117]    Module class: X.Org Video Driver
[    51.117]    ABI class: X.Org Video Driver, version 14.1
[    51.117] (II) NVIDIA dlloader X Driver  173.14.37  Wed Mar  6 17:02:37 PST 2013
[    51.117] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    51.117] (II) NOUVEAU driver Date:   Wed Jul 31 10:51:03 2013 +1000
[    51.117] (II) NOUVEAU driver for NVIDIA chipset families :
[    51.117]    RIVA TNT        (NV04)
[    51.117]    RIVA TNT2       (NV05)
[    51.117]    GeForce 256     (NV10)
[    51.117]    GeForce 2       (NV11, NV15)
[    51.117]    GeForce 4MX     (NV17, NV18)
[    51.117]    GeForce 3       (NV20)
[    51.118]    GeForce 4Ti     (NV25, NV28)
[    51.118]    GeForce FX      (NV3x)
[    51.118]    GeForce 6       (NV4x)
[    51.118]    GeForce 7       (G7x)
[    51.118]    GeForce 8       (G8x)
[    51.118]    GeForce GTX 200 (NVA0)
[    51.118]    GeForce GTX 400 (NVC0)
[    51.118] (II) VESA: driver for VESA chipsets: vesa
[    51.118] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    51.118] (II) FBDEV: driver for framebuffer: fbdev
[    51.118] (++) using VT number 7
[    51.120] (II) Loading sub module "fb"
[    51.120] (II) LoadModule: "fb"
[    51.120] (II) Loading /usr/lib/xorg/modules/libfb.so
[    51.120] (II) Module fb: vendor="X.Org Foundation"
[    51.120]    compiled for 1.14.3, module version = 1.0.0
[    51.120]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.120] (II) Loading sub module "wfb"
[    51.120] (II) LoadModule: "wfb"
[    51.120] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    51.121] (II) Module wfb: vendor="X.Org Foundation"
[    51.121]    compiled for 1.14.3, module version = 1.0.0
[    51.121]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.121] (II) Loading sub module "ramdac"
[    51.121] (II) LoadModule: "ramdac"
[    51.121] (II) Module "ramdac" already built-in
[    51.121] (WW) Falling back to old probe method for vesa
[    51.121] (WW) Falling back to old probe method for modesetting
[    51.121] (EE) open /dev/dri/card0: No such file or directory
[    51.121] (WW) Falling back to old probe method for fbdev
[    51.121] (II) Loading sub module "fbdevhw"
[    51.121] (II) LoadModule: "fbdevhw"
[    51.121] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    51.135] (II) Module fbdevhw: vendor="X.Org Foundation"
[    51.136]    compiled for 1.14.3, module version = 0.0.2
[    51.136]    ABI class: X.Org Video Driver, version 14.1
[    51.136] (EE) open /dev/fb0: No such file or directory
[    51.136] (II) NVIDIA(0): Creating default Display subsection in Screen section "Default Screen Section" for depth/fbbpp 24/32
[    51.136] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    51.136] (==) NVIDIA(0): RGB weight 888
[    51.136] (==) NVIDIA(0): Default visual is TrueColor
[    51.136] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    51.136] (**) NVIDIA(0): Enabling RENDER acceleration
[    51.136] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    51.136] (II) NVIDIA(0):     enabled.
[    52.407] (II) NVIDIA(0): NVIDIA GPU Quadro FX Go1000 (NV36GL) at PCI:1:0:0 (GPU-0)
[    52.407] (--) NVIDIA(0): Memory: 131072 kBytes
[    52.407] (--) NVIDIA(0): VideoBIOS: 04.36.20.30.d1
[    52.407] (II) NVIDIA(0): Detected AGP rate: 4X
[    52.407] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    52.407] (--) NVIDIA(0): Connected display device(s) on Quadro FX Go1000 at PCI:1:0:0:
[    52.407] (--) NVIDIA(0):     Sharp (DFP-0)
[    52.407] (--) NVIDIA(0): Sharp (DFP-0): 300.0 MHz maximum pixel clock
[    52.407] (--) NVIDIA(0): Sharp (DFP-0): Internal Dual Link LVDS
[    52.408] (II) NVIDIA(0): Assigned Display Device: DFP-0
[    52.408] (==) NVIDIA(0): 
[    52.408] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    52.408] (==) NVIDIA(0):     will be used as the requested mode.
[    52.408] (==) NVIDIA(0): 
[    52.408] (II) NVIDIA(0): Validated modes:
[    52.408] (II) NVIDIA(0):     "nvidia-auto-select"
[    52.408] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[    52.408] (--) NVIDIA(0): DPI set to (147, 145); computed from "UseEdidDpi" X config
[    52.408] (--) NVIDIA(0):     option
[    52.408] (WW) NVIDIA(0): UBB is incompatible with the Composite extension.  Disabling
[    52.408] (WW) NVIDIA(0):     UBB.
[    52.408] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[    52.408] (II) UnloadModule: "nouveau"
[    52.408] (II) Unloading nouveau
[    52.409] (II) UnloadModule: "vesa"
[    52.409] (II) Unloading vesa
[    52.409] (II) UnloadModule: "modesetting"
[    52.409] (II) Unloading modesetting
[    52.409] (II) UnloadModule: "fbdev"
[    52.409] (II) Unloading fbdev
[    52.409] (II) UnloadSubModule: "fbdevhw"
[    52.409] (II) Unloading fbdevhw
[    52.409] (--) Depth 24 pixmap format is 32 bpp
[    52.412] (II) NVIDIA(0): Initialized AGP GART.
[    52.415] (WW) NVIDIA(0): Failed to determine power source of the system : Unable to
[    52.415] (WW) NVIDIA(0):     find AC state file under /proc/acpi/ac_adapter/
[    52.416] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[    52.653] Loading extension NV-GLX
[    52.705] (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
[    52.708] (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
[    52.708] (==) NVIDIA(0): Backing store disabled
[    52.708] (==) NVIDIA(0): Silken mouse enabled
[    52.708] (==) NVIDIA(0): DPMS enabled
[    52.708] Loading extension NV-CONTROL
[    52.708] (==) RandR enabled
[    52.720] (II) SELinux: Disabled on system
[    52.721] (II) Initializing extension GLX
share|improve this question
    
Additional - when I boot up and it locks on the nvidia splash screen, I can ssh in and using top I find that apport is stuck on nearly 100% CPU –  Ritchie333 Jan 1 at 21:40
    
After hours of banging my head, I have fixed the problem. I ran apt-get remove --purge nvidia-173, then downloaded the latest drivers (173.14.39) from NVidia's website. The desktop then booted up as expected. The current Ubuntu nvidia-173 package still uses an earlier version of the driver (173.14.37), so it looks like somebody needs to rebuild and update that. –  Ritchie333 Jan 1 at 22:18

1 Answer 1

up vote 0 down vote accepted

(As per the OP's own answer in a comment:)

  1. Check on Nvidia's Unix Driver Archive or Driver Downloads which version of their drivers support your card (Quadro FX 1000). In this case it's 173.14.39.

  2. Check on packages.ubuntu.com if this package is provided for 13.10. If not (as is the case here), then check for it in the proposed repo (see how to search for proposed updates on ubuntu.com and BinaryDriverHowto/Nvidia). Unfortunately it seems that 173.14.39 isn't packaged for Saucy even in proposed: "nvidia-graphics-drivers-173" package in Ubuntu.

  3. If it were available in proposed, you'd have needed to enable it in Synaptic > Settings > Repos > Updates > Proposed and then install it. But since this is (currently) not an option, you can sudo apt-get remove --purge nvidia-173, then download the latest drivers (173.14.39) from Nvidia's website and install that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.