Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running Maverick very fluently, before I upgraded to Natty. However, the display performance seems fall down. For example, zoom desktop is very well in Maverick, but very slow in Natty.

I think it's caused by Unity. So I installed Gnome 3, using the source deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu natty main.

After installed Gnome 3, unfortunately it runs in fallback mode, and said maybe my graphics hardware is not supported.

$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)

Should I have to upgrade my graphics card? The card is bought 2 years ago, though.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Unity is implemented as a Compiz plugin, therefore it is just like a standard Compiz effect. Compared to standard Compiz effects, Unity uses quite a few hardware features of the graphics card. In addition, Compiz has been available on Linux for many years, therefore it is quite mature.

On the other hand, GNOME Shell has Mutter, a new window manager that does not use Compiz. Therefore, there will be differences. Mutter might have some bugs, or it might be even speedier than with Compiz. GNOME Shell cannot do all these Compiz 3D effects such as Cube, because it does not use Compiz.

What you should do is try out both, and look for any debugging messages that may explain performance issues.

share|improve this answer

for smooth desktop effect with intel graphic cards, you can disable "Sync To VBlank" option

first, install ccsm then go to Opengl -> untick Sync To VBlank option

share|improve this answer
    
I tried to disable VSync, unfortunately I didn't see any performance boost of Desktop Zoom. It's weired because Desktop Zoom is very smooth in Maverick, before upgrade to Natty. –  Xiè Jìléi May 4 '11 at 11:06
1  
i can confirm this, other effect like wobbly windows look smoother with this trick, but not with zoom effect maybe this is a bug in compiz have you created a bug report on lanchpad? –  soekarmana May 4 '11 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.