Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed Ubuntu 13.10 as the primary OS on my laptop. I installed Windows 8 in another partition and set up GRUB to be the boot loader. Eventually I updated Windows and it became a black screen so I reinstalled Windows in that partition. Somehow doing this removed Windows from GRUB's menu and so I tried to reinstall GRUB which I had a little trouble doing. I tried it a few different ways, one of them was booting from a LiveCD and involved mounting and unmounting things (did this pretty much blindly as I don't have a lot of the know how). That didn't work but I came across the standard boot-repair program and it worked fine.

The big problem I have no is that Ubuntu does not load after selecting it from GRUB. It just hangs at a black screen. When I select recovery mode, it goes to the menu. When I resume the normal boot, it reads out:

"Ubuntu 13.10 Denjay-Laptop tty1

Denjay-Laptop login:_"

With a flashing underscore. After a few seconds it then adds to that line "initct1: Event failed"

I also checked all the file systems with the recovery mode and with a LiveCD and nothing was anomalous on that end. I've also gone through updating GRUB so I think something wrong post-GRUB if that makes sense.

Any help would be greatly appreciated.

share|improve this question
1  
Was the OS ever booting into X or did you just install it? If it never booted, it may be a graphics card issue. –  Jeremy Jan 1 at 5:12
    
Do you mean Ubuntu? I installed it before ever using GRUB and at this point I would probably just do a clean install if I didn't have crucial files on there. There are libraries that I've gotten and worked on that would be extremely hard to get back. Also not quite sure what you mean by "booting into X". It worked before I booted from the LiveCD and tried to update GRUB. –  Denjay Jan 1 at 5:15
    
Completely agree with @Jeremy. This probably isn't a GRUB issue. Try to set the nomodeset parameter in Ubuntu through GRUB. See here how. If it loads correctly (with nomodeset I mean) then it is probably a graphics card driver issue. –  NikTh Jan 1 at 5:16
    
Tried nomodeset and it flashes the command line login prompt that I said before, then immediately goes to a black screen. –  Denjay Jan 1 at 5:25
    
What graphics card do you use? When I had a similar issue, I had too many drivers enabled. Try booting into recovery, opening up a root shell and typing dpkg --get-selecctions nvidia-*, replacing nvidia with whatever proceeds your drivers package name. Report the output. –  Jeremy Jan 1 at 5:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.