Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I first upgraded to Natty from 10.10 I went to fix my Compiz settings. First, the rotating cube wouldn't work. That was disappointing but not a huge deal. Later, every time I changed a setting in Compiz, my whole top toolbar with my clock, keyboard settings, calendar, etc. disappeared. I brought it back with a reboot, but that was only temporary.

Then I tried to install my nvidia drivers (I'm using an Asus UL50V) and after they were installed, I rebooted. Upon going back into Natty I was informed that Unity had crashed and was not compatible with my machine (I had already been using Unity for about a day at that point). Now I'm just running in Classic mode.

How can I get Unity back up and running? And once I do, what is there to do about my problems in the first paragraph?

Thanks!

share|improve this question
    
What nvidia drivers have you activated Bronte? –  wojox May 3 '11 at 22:18
    
I have installed my accelerated graphics driver. The Additional Drivers Page says "3D-accelerated proprietary graphics driver for NVIDIA cards. Required if you want to run Unity. This driver is required to fully utilise the 3D potential of NVIDIA graphics cards, as well as provide 2D acceleration of newer cards. You need to install this driver if you wish to use the Unity desktop, enable desktop effects, or run software that requires 3D acceleration, such as some games." –  Bronte May 3 '11 at 22:35
    
You didn't have an option to choose diffrent drivers? Mine let's me choose between nouvea, recommended, and 173.xxx I found 173 to be the best the others didn't work properly. –  wojox May 3 '11 at 22:38
add comment

2 Answers

Try to install bumblebee to have both the Intel and Nvidia cards working simultaneously: https://launchpad.net/~hybrid-graphics-linux

sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
# check the speed and compare to running:
glxgears
# If you have google-chrome installed, you can try it with/without optirun and report the FPS values on the mailing list:
optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.