Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install TeamViewer 9 from deb file however it says it needs ia32-libs so it won't install:

I tried to do some fix with sudo apt-get dist-upgrade but:

$ sudo apt-get install ia32-libs-multiarch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libglapi-mesa:i386
                            Depends: libglu1-mesa:i386 but it is not going to be installed
                            Depends: libqt4-opengl:i386 but it is not going to be installed
                            Recommends: libgl1-mesa-glx:i386
                            Recommends: libgl1-mesa-dri:i386
E: Unable to correct problems, you have held broken packages.

What is the work-around for this?

share|improve this question
    
Try with sudo apt-get --install-recommends install ia32-libs-multiarch libglu1-mesa libqt4-opengl –  user224082 Dec 31 '13 at 18:31
    
@DuminduMahawela Thanks that worked for me! I think you should make this an answer so I can accept it. –  xybrek Jan 1 at 14:35
    
Thanks for the feedback. –  user224082 Jan 1 at 15:26

2 Answers 2

up vote 1 down vote accepted

One of the way that unmet dependencies results is, when the installing package depend on other package which has its own dependent packages.

System installs only the installing package's dependencies. If those dependencies has their own dependencies (second level), then error of unmet dependencies results.

Here libglu1-mesa, libqt4-opengl also depends on other packages.

In such a case. it should be include the packages those not going to be installed to the installation list.

For extra safety, it is better to run --install-recommends to install the recommended packages even.

So run :

sudo apt-get --install-recommends install ia32-libs-multiarch libglu1-mesa libqt4-opengl
share|improve this answer

I have run into this issue before with other programs that have 32-bit dependencies.

To fix on Ubuntu, the following worked for me (through terminal):

sudo apt-get update
sudo apt-get install lib32gcc1

For Debian, you need to specify the architecture:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install lib32gcc1
share|improve this answer
    
Updated. Thanks @AvinashRaj! –  Ross Dec 31 '13 at 18:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.