Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

memory used by the compiz app (ID 1527) when session is started- 45-55 Mb, memory used after 2 hours, 500 MB. i found the following bug report https://bugs.launchpad.net/ubuntu/+source/unity/+bug/720446
has it been solved? is there a work around? is it related to the nvidia drivers?

share|improve this question

3 Answers 3

+1 for this being caused by the multiload indicator. My system was virtually unusable due to memory (or lack thereof) while it was installed. Left running long enough, the indicator will consume massive amounts of memory. When it was uninstalled, it was like a new computer.

share|improve this answer
    
It's 2014 now and there is still this issue with memory leak. I wonder if there is any alternative for indicator multiload ? –  Patryk Mar 10 at 18:49

I was having the exact same problem and was just about to report it when I saw your message. In my case, leaving the computer up and running overnight, the processes list in the system monitor said that Compiz was using about 2GB of memory (I have 4GB in my system).

Seeing the comment by Greg, I closed the multiload indicator and nothing has changed. (Yet. Perhaps it needs some time.) Processes still shows Compiz as using 2GB of memory. For all I know, though, it's actually now available for other processes to take as needed. I guess I'm saying that maybe you're right, Greg, but I haven't seen anything happen yet, but I'll keep the multiload indicator closed so I can see if the memory gets released.

As for Compiz itself, it's installed but I've never changed any settings at all.

And Oleg, your English seems just fine!

share|improve this answer
    
Maybe it would work to run compiz --replace& and then disown in a terminal to restart compiz w/o losing your desktop session? –  Azendale Jun 25 '11 at 0:04

The work around is to use open source driver for nvidea. If you had already installed proprietary driver, than you have to delete them first via "Additional driver" GUI. After the reboot there will be an additional driver option .

PC sorry for my English.

share|improve this answer
    
thanks for the response. i did try that and no luck. –  suli8 May 7 '11 at 13:51
    
yah... the same... i thought the problem was gone but it take just little longer. I Think we need to wait for update:) –  Олег Ницович May 8 '11 at 16:27
    
following the bug report, it could be related to the multiload indicator. we will see what will happen –  suli8 May 8 '11 at 21:28
1  
Although the proprietary nvidia driver is prone to causing problems, the open source driver is not really an option because the performance you get is far inferior to that of the proprietary driver. –  FuzzyQ Jun 29 '12 at 9:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.