Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I received an nintendo 64 usb controller and tried to use it to play (this one http://www.ebay.com/itm/Retrolink-Classic-Nintendo-64-USB-Controller-for-PC-and-MAC-BLACK-NEW-/360701283915?pt=US_Video_Game_Controllers&hash=item53fb78ce4b ).

So I put it,used this tutorial to install it http://ubuntuforums.org/showthread.php?t=338457 and I can see with jstest that it's working. So I installed mupen64plus and M64Py for the gui, so the gui recognize my controller, but I cannot use it. I saw on the post How do you configure mupen64plus controls? that I'm using the same controller than on the image tbe DragonRise inc one, but every time I change the controls and press enter or click on close it's just change all the controls by something per default like this:

DPad R = "key(100)"

DPad L = "key(97)"

DPad D = "key(115)"

DPad U = "key(119)"

Start = "key(13)"

Z Trig = "key(122)"

B Button = "key(306)"

A Button = "key(304)"

C Button R = "key(108)"

C Button L = "key(106)"

C Button D = "key(107)"

C Button U = "key(105)"

R Trig = "key(99)"

L Trig = "key(120)"

Mempak switch = "key(44)"

Rumblepak switch = "key(46)"

X Axis = "key(276,275)"

Y Axis = "key(273,274)"

Normally the buttons should be like button 1,2,3 etc

I tried with the gui and without the gui but I cannot make this controller workinf :/ Thanks for reading and sorry for my poor english

share|improve this question

1 Answer 1

You should ask this question on the mupen64 forums, asking us will get you nowhere.

It's probably mupen64s fault.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.