Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want my computer automatically boot my Ubuntu system. But it always starts with this list:

Linux 3.2.0-57-generic-pae
Linux 3.2.0-57-generic-pae (recovery mode)
Linux Privous
Memory test (memtest86+)

I want my computer to automatically boot into Linux 3.2.0-57-generic-pae.

This is my /etc/default/grub file:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash mem=4G video=LVDS-1:d"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
share|improve this question
    
Does this help? –  Wilf Dec 31 '13 at 7:05
    
Does that link help? Look at the duplicate as well. –  Wilf Jan 2 at 9:27

1 Answer 1

Run this:

sudo nano /etc/default/grub

and set this line to saved, and remove any # from it as well:

GRUB_DEFAULT=saved

also, set this line to true:

GRUB_SAVEDEFAULT=true

If these lines are not in the file, add them in.

Edit: To get rid of GRUB completely, set this to 0:

GRUB_TIMEOUT=0

but as it is sometimes useful for GRUB to be shown, to recover the system, or boot to a different kernel, you may want to set this to 1 or 2 seconds:

GRUB_TIMEOUT=2

you could also hide the menu unless a key is pressed during the 2 seconds time period:

GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=2

Then save with Ctrl+O, and exit with Ctrl+X.

Then run:

sudo update-grub

which will update the configuration. Now, it should automatically select as default the entry you selected previously, and disappear after a timed delay, and hide if you wish it.

More on editing grub here

share|improve this answer
    
Depening on your approach, I still didn't solve the problem. Thank you. –  Jeffrey Dec 31 '13 at 8:34
    
It is still not work out. –  Jeffrey Jan 2 at 1:49
    
Try sudo grub-reboot 0 command on terminal. –  Avinash Raj Jan 2 at 12:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.