Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Chrome Version : 31.0.1650.63 (Official Build 238485) Extensions : Google docs, Lastpass

Im on a brand new system, just installed Ubuntu. When I open chrome, normally the search box, alert windows are styled according to my current system GTK theme. But now they look like classic windows theme! Tried different themes and adjusting the theme under Settings > Appearance in Chrome but still no use. How to fix this?

Here's a screenshot :

enter image description here

share|improve this question

3 Answers 3

I ran into this problem and it turns out it was a result of running a 32-bit version of Chrome on my 64-bit version of Ubuntu. Once I realized the mistake, I reinstalled and the issue went away.

share|improve this answer

Open ~/.config/google-chrome/Default/Preferences with a text editor and ensure that you have:

  "theme": {
     "id": "",
     "use_system": true
  },
share|improve this answer

To fix this (just for Chrome)

(See below for an answer that will work for all 32-bit applications, even Skype)

user140840's answer has the key: Accidentally running the 32-bit version of Chrome will lead to this problem. Fortunately, it is easy to fix as the Chrome repository is now already installed:

sudo apt-get remove google-chrome-stable:i386
sudo apt-get install google-chrome-stable

To also remove the unnecessarily installed 32-bit packages that you don't need anymore, run:

sudo apt-get autoremove

Then, you need to either restart Ubuntu or kill all running google-chrome processes:

killall google-chrome

Your settings will all still be there, and windows and menus should look correctly now.

To fix this permanently for all 32-bit applications (e.g. Skype)

You need to install the 32-bit versions of the GTK2 packages responsible (source):

sudo apt-get install gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386

Then close and restart the 32-bit application.

(both fixes tested and working on Ubuntu 14.04)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.