Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 (WUBI) on my Toshiba Sattellite. I have a Realtek RTL8188E Wireless LAN 802.11n. The internet works fine when I plug it in using a ethernet cable, but my laptop doesn't even search for wifi. I have Windows 7 and my wifi works fine. How do I make my wireless internet work?

When I command lspci -nn | grep 0280 I get Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)

share|improve this question

This question has an open bounty worth +50 reputation from Andrew ending in 4 days.

The current answer(s) are out-of-date and require revision given recent changes.

I have a Toshiba satellite c55-a5105 laptop and it has that wireless card. I am using Kubuntu 14.04. When I try this answer it output this error which you can see in this log. I was having issues with the touch-pad but got it working. But no luck with the FN key.

    
I mean that I dual boot with Windows 7 and the wireless internet works fine on it. –  Austin Dec 31 '13 at 4:11
    
Please edit your question to add details of your wireless card from the terminal command: lspci -nn | grep 0280 –  chili555 Dec 31 '13 at 13:43

2 Answers 2

Please get a temporary wired ethernet connection and do:

sudo apt-get install linux-headers-generic build-essential

I suggest you download this to your desktop: https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.12.2/backports-3.12.2-1.tar.bz2 Right-click it and select 'Extract Here.' Now open a terminal and do:

cd ~/Desktop/backports-3.12.2-1/
make defconfig-rtlwifi
make
sudo make install
sudo modprobe rtl8188ee

Your wireless should now be working. You will have compiled the driver for your currently running kernel only. When Update Manager installs a later linux-image, after reboot, re-compile:

cd ~/Desktop/backports-3.12.2-1/
make clean
make defconfig-rtlwifi
make
sudo make install
sudo modprobe rtl8188ee

If the message logs say you need firmware:

dmesg | grep rtl

Download and install it with:

wget http://mirror.pnl.gov/ubuntu//pool/main/l/linux-firmware/linux-firmware_1.106_all.deb
sudo dpkg -i linux*.deb 
sudo modprobe -r rtl8188ee && sudo modprobe rtl8188ee
share|improve this answer
    
Thank you it worked! –  Austin Jan 2 at 5:29
    
I had to go through all of the firmware stuff, but eventually got it to work on Debian 7 as well. Thank you! –  Chris Feb 21 at 6:18
    
doesn't work... paste.ubuntu.com/8069197 –  Andrew 2 days ago
    
@Andrew What kernel version are you running? uname -r –  chili555 2 days ago
    
3.13.0.34-generic humm it is unstable. –  Andrew 2 days ago

guys. I did it. However, i had one little problem: in the first time that i tried, i got the message "CONFIG_X86_X32 enabled but no binutils support". Well, i'm brazilian and here Ubuntu calls "desktop" as "Área de trabalho" (with spaces and acute) and the answer to this question saved me.

P.S: Sorry for english.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.