Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to press Shift+Insert and have that execute a paste from the clipboard (the thing that Ctrl+C copies to) inside of gnome-terminal.

In 13.10, Shift+Insert pastes from the selection buffer (the thing that selecting text writes to). In Libre Office, Chrome, and Firefox, Shift+Insert pastes from the clipboard. I would thus like to configure gnome-terminal to do the same.

I would not like to use Ctrl+Shift+V. EDIT: I phrased this poorly. I would still like to use Ctrl+Shift+V but I did not want people to post that as a solution. The reason why I would like to use Shift+Insert is because a program I use sends the keys Shift+Insert assuming that it will paste.

Unfortunately, in gnome-terminal there is no setting for this under Edit → Profile Preferences → Compatibility, nor is there under Edit → Keyboard Shortcuts.

The only other related post I can find is: how to restore proper X clipboard behaviour (shift+insert) in 12.10? which I think prefers the opposite of what I prefer and is probably happy now with the change.

share|improve this question
    
Do you want both Ctrl+Shift+V and Shift+Ins to paste the clipboard in Gnome Terminal? –  minerz029 Jan 3 at 21:39
    
I don't understand... I do use <kbd>Shift</kbd>+<kbd>Insert</kbd> in my terminal to paste clipboard. And it's a (almost) freshly installed Ubuntu 13.10. The only extra thing I remember installing is vim. –  GabrielF Jan 8 at 23:06
    
@GabrielF strange. Thanks for the information. I will do some more checking. –  Xu Wang Jan 9 at 7:07
add comment

4 Answers 4

up vote 2 down vote accepted
+50

There is a simple workaround for what you need.

  1. First you will have to install xdotool Install xdotool.

  2. Then launch the Keyboard configuration gnome-control-center keyboard:
    (Go to Shortcuts → Custom shortcuts)

    enter image description here

  3. Click on "+" and add a name like "Paste into terminal" and the command

    xdotool key --clearmodifiers ctrl+shift+v
    

    enter image description here

  4. Then choose Shift+Insert as the key binding:

    enter image description here

Because of a bug, you will have to logout and log back in so the shortcut can take effect.

share|improve this answer
add comment

There is a relatively simple answer:

  1. Open Gnome Terminal.
  2. Open Edit → Keyboard Shortcuts.
  3. Click on the old "Ctrl+Shift+V" shortcut for Paste until it changes to New accelerator, then press Shift+Insert.
  4. Close the Preferences window.
  5. Shift+Insert should now paste the clipboard.
share|improve this answer
add comment

If you don't want to use SHIFT+CTRL+V, then why not just change that paste hotkey to SHIFT+INSERT under Edit > Keyboard shortcuts?

I installed gnome-terminal on lubuntu 13.10 and I have that option (see screenshot I already changed it there). If you don't have it you might try to change that setting in gconf-editor, see the screenshot.

enter image description here

share|improve this answer
    
How? I don't see that shortcut under there. Are you sure it's there for 13.10? Which submenu do you see it ("Launchers", "Navigation", ...)? –  Xu Wang Jan 2 at 22:24
    
@XuWang I have that option on lubuntu 13.10. Is the gnome-terminal different for ubuntu 13.10? I updated my answer. –  falconer Jan 2 at 23:14
add comment

There really is no way to add custom keyboard shortcuts to the gnome terminal, sorry bud...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.