Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I am getting a message

Could not update ICEauthority file /home/me/.ICEauthority

When trying to log into ubuntu graphical. Terminal works (ctrl alt f1)

not a duplicate of:

What does this startup dialog message mean "Could not update ICEauthority file"

In my case my .ICEauthority is -rw------- 1 me me ...

Things I tried to do to fix this:

  • reset the ICE file's permissions in case something was messed up that I did not notice.
  • delete the file (no new one was created)
  • touch a new file after the orig was deleted
  • looks like my home directory was owned by root. fixing did not help.
  • .ecryptfs has correct permissions on my home directory
  • autologin is off, never was turned on
  • fresh install so no password changes (i'd prefer not to re-install my os because I did spend a day setting it up)
  • only weirdness found was: /home/.ecryptfs/me/.ecryptfs/wrapped-passphrase is -rw------- 1 me root 48 ..... however that should not be an issue or so it would seem due to permissions

I installed gnome after installing the system

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install gnome-shell

never booted into it (or anything else rather except for tty) successfully

Looks like so far nothing good coming out of this. Unfortunately if I can't solve this I will just reinstall the distro :(

share|improve this question

closed as off-topic by Braiam, Radu Rădeanu, Eric Carvalho, BuZZ-dEE, Avinash Raj Apr 23 at 1:37

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, Radu Rădeanu, Eric Carvalho, BuZZ-dEE, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Can you check the ownership of your home directory? You may need to chown that too. –  Mark Russell May 3 '11 at 19:25
    
Did you try a reboot with failsafe? Might be a shot in the dark but did you turn on 'automatic login'? (a couple of releases ago that was an issue too ... turn it off and try again). command line: gksudo gedit /etc/gdm/custom.conf –  Rinzwind May 3 '11 at 19:40
    
maybe you already did, but just in case, use chown -R on your home dir so it gets everything. –  Mark Russell May 3 '11 at 19:41
    
Is it possible you changed your user password recently and did not change your ecryptfs password separately? –  Mark Russell May 3 '11 at 19:46
    
@Mark did not do chown -r. –  Dmitriy Likhten May 3 '11 at 19:54

7 Answers 7

I just had the same issue. I got rid of it by using the following command ~

sudo chown user:user /home/user

Replace user by your user name.

Cheers!

share|improve this answer
    
Thanks +1 I have no idea how my home directory's owner became root. –  TheLukeMcCarthy Oct 3 '13 at 12:13
up vote 1 down vote accepted

I am going to re-install ubuntu. Cannot debug this. Probably gnome3 install borked it.

share|improve this answer
2  
Hope I am not too late but did you see this topic: ubuntuforums.org/showthread.php?t=1742343 Gnome3 is indeed the culprit! –  Rinzwind May 5 '11 at 14:17
    
too late :( o well gnome2 works out of the box... –  Dmitriy Likhten May 9 '11 at 11:57
    
Not sure if my case is the same, but I got the same error trying to login with "gnome classic" and "Safe Mode". So maybe it's not just gnome3's issue. –  Tom Brito Aug 3 '11 at 12:54

Yes, there is a problem in Gnome, here is the solution, instead of uninstall and re install ubuntu, at least you can save your data backup

sudo apt-get install lxde

Installed after that do Ctrl-Alt-F7 to get back to the login screen,

now select lxde in the drop down menu, entered my password, you can able to now login to an LXDE session

share|improve this answer

I fixed a similar. ICEAuthority problem which due to the aes module can't be installed in booting, for padlock not detected, in a word, you should blacklist the padlock_aes module like:

cat /etc/modprobe.d/blacklist-ecryptfs.conf
blacklist padlock-aes 

I also post the detailed steps, FYI.

share|improve this answer
    
You cannot change the contents of a file using cat with the syntax you've presented. You may want to edit your question to clarify how you're suggesting people do this. There's a method that looks a little bit like what you've written, but which is syntactically different, where you run cat >> /etc/modprobe.d/blacklist-ecryptfs.conf, then enter blacklist padlock-aes, then on a new line press Ctrl+D. Is that what you mean? –  Eliah Kagan Jun 18 '12 at 10:52

I had the same issue, After reading posts about using "chown" on .ICEauthority, I decided to try changing the Read/Write permission on the file .ICEauthority with "chmod".

It was originally: -rw------- So I changed it to: -rw-rw-rw-

And it worked! (I used "chmod 666 /home/$USER/.ICEauthority")

Worth a try I suppose...

share|improve this answer

I had the same problem and here is how i fixed it... - I logged into the system as root - deleted the user account that had the ICEauthority error (userdel user) - I then recreated the same account only this time i used a -m switch that created a home directory for the user(useradd -m user) - I set the passwd to the account using this command (passwd user) - I logged out of my root account. - Logged in using the new account and VOILA, the no more ICEauthority problems. - Login was Successful.

  • I think the problem might have been when you created the user account, u didn't tell the system to create the home directory for that particular user.

  • If this works for you let us know.

share|improve this answer

I was having the same problem, in my case my home directory permission got changed to root somehow.

changed it to user and it worked:

cd /home
sudo chown user:user <homedir>

I did not use -R flag option because taking a long time to change all the permission, moreover permissions to file/dir inside the homedir was already user.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.