Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Error mounting /dev/sdd1 at /media/nevos/Elements: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdd1" "/media/nevos/Elements"' exited with non-zero exit status 12: Failed to read last sector (3907027119): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdd1': Invalid argument
The device '/dev/sdd1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
 (udisks-error-quark, 0)

I am a beginner so plz help!

share|improve this question
    
Did you install the ntfs-3g implementation? –  troylatroy Dec 30 '13 at 21:37
    
no? how do you do that? –  nevil Dec 30 '13 at 21:49
    
Just put this into the terminal sudo apt-get install ntfs-3g –  troylatroy Dec 30 '13 at 22:08
    
ok put that into terminal then what? still not up and running –  nevil Dec 30 '13 at 22:13
    
I think the problem is in your code syntax. Try something like this mount /dev/sdd1 /media/nevos/Elements -t ntfs -o uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177 –  troylatroy Dec 30 '13 at 22:24
show 5 more comments

1 Answer 1

The drive is corrupt. I have seen reports by other users of this happening. It seems that this particular drive is shipped with a corrupt filesystem formatted on it, most likely because it was formatted prior to being installed in the USB enclosure, and the enclosure makes the drive appear slightly smaller than it really is. You will need to reformat the drive, and you should complain to WD so they stop shipping broken drives.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.