Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I didn't want to reinstall my ubuntu to xubuntu so i decided to install xfce4 on Ubuntu 13.10 with: sudo apt-get install xfce4

I logued on for first time and the sound was working well. However after a reboot the sound didn't work anymore...

I tried: - reinstalling alsa => didn't work

  • reinstalling xfce4-mixer => didn't work

  • adding options snd-hda-intel model=laptop-eapd to /etc/modprobe.d/alsa-base.conf => didn't work

  • speaker-test -c 6 => no sound

I am out of idea now.I thank in advance those who have an idea that could help me.

My config:

Laptop Asus N56VZ

Ubuntu 13.10 - xfce4

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Answer 1: From the terminal, run xfce4-mixer or even easier, if you have the speaker icon on your panel (i.e. which you can easily add to your panel if it's not there, just right-click on the panel and move around, it's not hard) right-click it, chose to run the audio mixer, make sure you are on the playback tab. Your master, headphone and speaker levels should be un-muted and high enough for you to listen to anything.

The problem is that when you mute your volume again, only the master responds reasonably. But the speaker and headphone levels get muted and never back to un-muted. So I have to manually un-mute the headphone and speaker levels.

enter image description here

I tried a solution which didn't work for me, but may be for others. It's about sudo editing a file: /etc/modprobe.d/alsa-base.conf and append this line to it: options snd-hda-intel model=laptop-eapd, then reboot, but this didn't work for me.

I'm using a Dell Inspiron SE 7520, Ubuntu 13.10, Xfce 4.12.

Answer 2: Log out of Xfce, log in using Unity, un-mute your voice (This is the trick. I found my sound muted on Unity). Logout and login again using Xfce.

What still bothers me, is that when I muted the sound on Xfce, the problem occurred again. No sound at all even if I un-mute it while I'm still on Xfce !

share|improve this answer
    
I have reinstalled alsa and pulseaudio and it worked: sudo apt-get remove --purge alsa-base sudo apt-get remove --purge pulseaudio sudo apt-get install alsa-base sudo apt-get install pulseaudio sudo alsa force-reload –  Chewbye Jan 26 at 19:14
    
I have uninstalled xfce4 and xubuntu-desktop, a while after that I reinstalled xfce4 only, and this issue didn't occur again. I cannot confirm that installing xubuntu-desktop caused this problem. You can, though to you don't have to, up-vote this answer :) –  Muhammad Gelbana Jan 26 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.